Skip to content

Commit

Permalink
media-libs/mutagen: Bump to version 1.36
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.3, Repoman-2.3.1
  • Loading branch information
Lars Wendler committed Dec 25, 2016
1 parent e43ca7c commit 948b9f0
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/mutagen/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST mutagen-1.31.tar.gz 897785 SHA256 0aa011707785fe30935d8655380052a20ba8b972a
DIST mutagen-1.34.1.tar.gz 872058 SHA256 aacd667ef1f4fa7b7c201f36b2a6eda1ead3c92331017601d8082af62a7ee461 SHA512 bd3e49b4b176611f673dfc8288def8f7f268077b231df7a4dab93d1cfb14ae4538f9c02c4157e074f3356d0883758d679893c8e4906a612bfb7c9593416cdb2a WHIRLPOOL 5c0ba1b6b1e26c5ea11f0386b4db981f4b99422ae8373e2a88ff971e706503a1e33b0b595d77e2e993279f19e5fe19813310d89d043e5103d46a4e5f96dbde4b
DIST mutagen-1.35.1.tar.gz 883772 SHA256 49cda72ee5213e60d5d48a80187b0b17d37a6244f37751f72e480c1b1832934e SHA512 e411b86d50a7689589b7d300317dc2a2c4893efe47b66d07bdf5fe92f1d08fcc00c314e3ae1f97d706fcaae6c83c7569bb22b557af2dfc469b1d3c4f0388a260 WHIRLPOOL 6662ed461122fae69cf8844f6460ae8635cc1b7b3e5faf13f83a51d8f02bac927c8d850f727f602ba83b3be41e3c5c28b4ea2dfa2564710d525f5a699992f0e7
DIST mutagen-1.35.tar.gz 884988 SHA256 ee106f1544e8caf688102afaca2fe95cab4caf144da06128a265a29c8c7f4619 SHA512 68a3d30300bbfbedad39f76798827b70b9dd6bbb72da3b0f537748f76b395866aeaacbb1ca9d64d11d1c97a09e5767bcac98131d62846f91172a1caf8d434a50 WHIRLPOOL 149d27c832527a2cd8986f56b50c5865320aec69bd1452ce71cb96fc47a8a0227e9b7defe05e94aa64e9d9226dd9faf3cfba6af0788f90d073346c3afd219c1b
DIST mutagen-1.36.tar.gz 888238 SHA256 d7ee37e33b8c5893c3ebf66edac31241eb9d48e1dc7ec647bbfbc180565a4bcd SHA512 82aabebdd5df5a6e68a6e983073feced972c5cfd74711c52d12559617fd29ed0835a9067ea5b8b7be7fb34dda0b9c46b81dfa0338834eedfe7e482e2cfcc249f WHIRLPOOL 7628247a475f9b56eea972a36e7ed6aca7a9cfeaa80055f472e0b537af55a68a38cf56faabad24040ae0e82fa2d2d028e304a135d33bf274bf14a58d0f91cd27
46 changes: 46 additions & 0 deletions media-libs/mutagen/mutagen-1.36.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

PYTHON_COMPAT=( python{2_7,3_4,3_5} )

inherit distutils-r1

DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
HOMEPAGE="https://bitbucket.org/lazka/mutagen https://pypi.python.org/pypi/mutagen"
SRC_URI="https://bitbucket.org/lazka/${PN}/downloads/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
IUSE="doc test"

# TODO: Missing support for >=dev-python/eyeD3-0.7 API
# test? ( >=dev-python/eyeD3-0.7 )
RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

python_compile_all() {
use doc && emake -C docs
}

src_test() {
# tests/test_flac.py uses temp files with a constant path.
# If we had multiple python implementations, we would hit a race.
distutils-r1_src_test
}

python_test() {
esetup.py test
}

python_install_all() {
local DOCS=( NEWS README.rst )
use doc && local HTML_DOCS=( docs/_build/. )
distutils-r1_python_install_all
}

0 comments on commit 948b9f0

Please sign in to comment.