Skip to content

Commit

Permalink
dev-python/ipyparallel: Bump to 8.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 15, 2023
1 parent 89345ef commit 949eb98
Show file tree
Hide file tree
Showing 2 changed files with 88 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/ipyparallel/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST ipyparallel-8.4.1.tar.gz 6843301 BLAKE2B 1ca0056cfa6827f5eb145584ea634d224119a485f1139964988b07bcd164fe392bb032794098bccdf67b31f74030e62e917c0a451809e0d14fae323308b2b0ab SHA512 640489b3920b91e1b2f83def00a06e8ec45c61bd7ebe33a3e4a30560e2b0acdbe0a98a685d868dd7bce4c65920d378ab69efca75cf0ae7f164ee792c870a297e
DIST ipyparallel-8.5.1.tar.gz 6807242 BLAKE2B 28d60bd58f66fd24ef4fd2dfdf37facd4d7cc6769abc186e37133bd2a16cabea029c33e23f8b79b9024943251f411e49eb07b10978ea78964a01a666f5cf6b52 SHA512 78ed082d01191681d4999254d925911c68952509668ced0d3d65e50f0f67ba687c2ef8f4d4282f181f04951d6872a03b675d4d478f41c47692d294d817e15391
DIST ipyparallel-8.6.0.tar.gz 6807596 BLAKE2B 4a81ad39d12dd12930047c7a5141b3dfe0e8e53bf7d17f936e1fa71fd64354f88ab9817ebbe9944aefd11b374d5d6d564b77f3fc657582670eedc536fbc6e173 SHA512 42c642ae11164c79a52b07436d6ce672db1faf7bfdc0871e507baf0a44b8bf50f6e73b6176f9c92e4b484429545b99273a7e51e735c70c26dfa608b27d373805
DIST ipyparallel-8.6.1.tar.gz 6807935 BLAKE2B 23847974e9d5d1d06a64a6b01c845f539848c602b6ba6a22c64d8e0bd35a783ec3a09fc6618ae08490d35e49d497c1db61176f8c70065c4e61ec234a7fd00545 SHA512 e83447f9d52eed87e8513d2ee74d2d6b589a5c04b5bf6dfece6d87565dd9c5e46abd280eb5ab64266b2e759dec1007ab007d0b8232b6239768190bd6900f53ff
87 changes: 87 additions & 0 deletions dev-python/ipyparallel/ipyparallel-8.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="threads(+)"

inherit distutils-r1 optfeature pypi

DESCRIPTION="Interactive Parallel Computing with IPython"
HOMEPAGE="
https://ipyparallel.readthedocs.io/
https://github.com/ipython/ipyparallel/
https://pypi.org/project/ipyparallel/
"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"

RDEPEND="
dev-python/entrypoints[${PYTHON_USEDEP}]
dev-python/decorator[${PYTHON_USEDEP}]
>=dev-python/pyzmq-18[${PYTHON_USEDEP}]
>=dev-python/traitlets-4.3[${PYTHON_USEDEP}]
>=dev-python/ipython-4[${PYTHON_USEDEP}]
dev-python/jupyter-client[${PYTHON_USEDEP}]
dev-python/jupyter-server[${PYTHON_USEDEP}]
>=dev-python/ipykernel-4.4[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
>=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
dev-python/tqdm[${PYTHON_USEDEP}]
>=dev-python/tornado-5.1[${PYTHON_USEDEP}]
"
BDEPEND="
dev-python/flit_core[${PYTHON_USEDEP}]
test? (
dev-python/ipython[test]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-tornado[${PYTHON_USEDEP}]
dev-python/testpath[${PYTHON_USEDEP}]
)
"

# TODO: package myst_parser
# distutils_enable_sphinx docs/source
distutils_enable_tests pytest

PATCHES=(
"${FILESDIR}"/${PN}-7.1.0-test-timeouts.patch
)

src_configure() {
export IPP_DISABLE_JS=1
}

python_test() {
local EPYTEST_DESELECT=(
# we don't run a mongo instance for tests
ipyparallel/tests/test_mongodb.py::TestMongoBackend
# TODO
ipyparallel/tests/test_util.py::test_disambiguate_ip
# Gets upset that a timeout _doesn't_ occur, presumably because
# we're cranking up too many test timeouts. Oh well.
# bug #823458#c3
ipyparallel/tests/test_asyncresult.py::AsyncResultTest::test_wait_for_send
# We could patch the timeout for these too but they're going to be inherently
# fragile anyway based on what they do.
ipyparallel/tests/test_client.py::TestClient::test_activate
ipyparallel/tests/test_client.py::TestClient::test_lazy_all_targets
ipyparallel/tests/test_client.py::TestClient::test_wait_for_engines
)
epytest
}

python_install_all() {
distutils-r1_python_install_all
# move /usr/etc stuff to /etc
mv "${ED}/usr/etc" "${ED}/etc" || die
}

pkg_postinst() {
optfeature "Jupyter Notebook integration" dev-python/notebook
}

0 comments on commit 949eb98

Please sign in to comment.