Skip to content

Commit

Permalink
app-crypt/jitterentropy: bump to 3.3.1
Browse files Browse the repository at this point in the history
Signed-off-by: Göktürk Yüksek <[email protected]>
  • Loading branch information
gktrk committed Feb 12, 2022
1 parent 4de55a4 commit 954fb68
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-crypt/jitterentropy/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jitterentropy-2.2.0.tar.gz 25556 BLAKE2B d0a8faa9131e9fd5712fad4179725ac29ba813e0d77e5ae9dc905841b92f67fc51e79c407142b2e8c3473f92a59a5b03f03d2013bd7e5d1ae07110da52461255 SHA512 4701a7e0a82ee583cbde5edfdacb737a5f588b42c61b16434b5a11bdfb1a108e7b9df8b8b38d9e92290e702b33f2ae8774580d6a71e6e8ac3af295ffc8ff5ff9
DIST jitterentropy-3.0.1.tar.gz 31212 BLAKE2B 522e9b88e96ed1e6f57e793779c46f7799185f9d25390268f628eb309239a3522ac13277a037acf54dcce7e7b1364b2ec6e15d21a5f13aaa5a87ece7690d57fd SHA512 fd195e150ea861fcd5ff72a84f48ef8b7d0d8a3d44aae51f0fe5c39a1d1409ca98271a6cf06140fa8b6aba08d8bbbddf097cd7d99b5c1b698db08f056236e547
DIST jitterentropy-3.3.1.tar.gz 81596 BLAKE2B ad8bf87d5a30b4bc98a3af7c1dcff442516c0330050aea90f2f05d68c4c2f1e9fe4b8db885f00dcd138ae7cb5a6ca58800686ae507f0e41596c95176a33e2b96 SHA512 7dc17c377cf90d38057bbc135e00730a3f84bc66aeed83eca1ad1b0e1c2fb89c5346ec20bdf25d3ce27f1d21893d44e52c08e96175554c18dfa1934a8d4fd9f7
46 changes: 46 additions & 0 deletions app-crypt/jitterentropy/jitterentropy-3.3.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit flag-o-matic toolchain-funcs

DESCRIPTION="Hardware RNG based on CPU timing jitter"
HOMEPAGE="https://github.com/smuellerDD/jitterentropy-library"
SRC_URI="https://github.com/smuellerDD/jitterentropy-library/archive/v${PV}.tar.gz -> ${P}.tar.gz"

# For future reference, tests/raw-entropy/validation-{restart,runtime}
# have a weird license clause where it says:
# The licensee IS NOT granted permission to redistribute the source code or
# derivatives of the source code, and the binaries compiled from the source
# code or its derivatives to any third parties.
# Do not package these two components!
LICENSE="BSD"
SLOT="0/3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~x86"
IUSE="static-libs"

S="${WORKDIR}/${PN}-library-${PV}"

src_prepare() {
default

# Disable man page compression on install
sed -e '/\tgzip.*man/ d' -i Makefile || die
}

src_compile() {
# Upstream defines some of CFLAGS in the Makefile using '?='
# This allows those default flags to be overwritten by
# user-defined CFLAGS. Restore some of the defaults.
append-cflags '-fwrapv' '-fvisibility=hidden' '-fPIE'
emake AR="$(tc-getAR)" CC="$(tc-getCC)"
}

src_install() {
emake PREFIX="${EPREFIX}/usr" \
LIBDIR="$(get_libdir)" \
DESTDIR="${D}" \
INSTALL_STRIP="install" \
install $(usex static-libs install-static '')
}

0 comments on commit 954fb68

Please sign in to comment.