Skip to content

Commit

Permalink
dev-php/symfony-process: Add version 3.2.6
Browse files Browse the repository at this point in the history
Add version bump 3.2.6

Gentoo-Bug: 613898
  • Loading branch information
GuillaumeSeren authored and orlitzky committed Apr 25, 2017
1 parent 94dc626 commit 95a1c50
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/symfony-process/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST symfony-process-2.8.12.tar.gz 29787 SHA256 86cd9300ecb870a88d843363fa0a7415e0ee3b7815c94f76ccb21b901075337b SHA512 2956572f394aa58e784f7b2b3922f4c8f1d71d5eb9859b757ce5986776d3e960ffbfcee2fb55ff89c176362a5ee0276d3b71ef00ae7338be1761bd88b4116294 WHIRLPOOL 8ede35f972146645c4d75855cd9b8ea0c51a746698d952c3c6716ae0fbe138abe551f432a2bd9e2afe3945cff7ea9021bb102486fbc8c60c2528f78d083983ee
DIST symfony-process-3.2.6.tar.gz 31684 SHA256 aaf955e88bc79f3304cebbb272c12b9faa9b07354ba3dce8793fa1a0766400b9 SHA512 8fd7712b2f63a46b6dea0b6cb76825c1e4c7b6a33123fe0949fedec820e599ffe5175bac567e8b453be7964f8b070bc2a2b9554b102a33834dfdbe959a23a3d4 WHIRLPOOL 9607ee99bd0314ad32d4ec5be42f4b2e4ceb3d7a953a5133dcb2a32e50ce7b1572dbd092ab92f4e01b441531b8a9751b0a7b971eb4df97d87acb44312182aa1f
43 changes: 43 additions & 0 deletions dev-php/symfony-process/symfony-process-3.2.6.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DESCRIPTION="Symfony Process Component"
HOMEPAGE="https://github.com/symfony/process"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RESTRICT="test"

RDEPEND="
dev-lang/php:*
dev-php/fedora-autoloader"
DEPEND="
test? (
${RDEPEND}
dev-php/phpunit )"

S="${WORKDIR}/process-${PV}"

src_prepare() {
default
if use test; then
cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
fi
}

src_install() {
insinto "/usr/share/php/Symfony/Component/Process"
doins -r Exception/ Pipes/ ExecutableFinder.php InputStream.php \
LICENSE PhpExecutableFinder.php PhpProcess.php ProcessBuilder.php \
Process.php ProcessUtils.php "${FILESDIR}"/autoload.php
dodoc README.md
}

src_test() {
phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
}

0 comments on commit 95a1c50

Please sign in to comment.