Skip to content

Commit

Permalink
dev-java/jdbc-mysql: bump to 8.0.25
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/565036
Package-Manager: Portage-3.0.18, Repoman-3.0.2
Signed-off-by: Volkmar W. Pogatzki <[email protected]>
Closes: gentoo#21093
Signed-off-by: Miroslav Šulc <[email protected]>
  • Loading branch information
vaukai authored and fordfrog committed Jun 3, 2021
1 parent 2f5fed6 commit 95bc042
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/jdbc-mysql/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jdbc-mysql-8.0.25-sources.jar 1556319 BLAKE2B 75eb4837f6916247650a925f87d52e49848e3bc52cfa683a149624e4b749c3c4b3a7336a5659dd0c894f0285254c915364d9ffd7b4779c87e0894053a2854a5c SHA512 c4384213845c43a494360131dcb7b9b424473237b65504d5ed4a7929cb8bb7b4b3c7cce6fde2c20a7026891751e76c78ea64af746a053ca42567a7e68782280e
DIST mysql-connector-java-5.1.26.tar.gz 3724076 BLAKE2B b5477e0f86a04b2135a47e3551cc89fa5f63f46faaccbf1e4473eb59e6d266d22d76a5c256d125feeeccd4625c22bcedaa9e21e613bf9759459e106b7d30db5f SHA512 93b882f5262dc991aa885ed9ae7fead02b9d28431022c86c6724272b508e78eee3df7310e9964e60f68953ed56f4fcdf9159a90f463eb39aea65af2453371879
54 changes: 54 additions & 0 deletions dev-java/jdbc-mysql/jdbc-mysql-8.0.25.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

# Skeleton command:
# java-ebuilder --generate-ebuild --workdir . --pom mysql-connector-java-8.0.25.pom.xml --download-uri https://repo1.maven.org/maven2/mysql/mysql-connector-java/8.0.25/mysql-connector-java-8.0.25-sources.jar --slot 0 --keywords "~amd64 ~ppc64 ~x86" --ebuild jdbc-mysql-8.0.25.ebuild

EAPI=7

JAVA_PKG_IUSE="doc source"
MAVEN_ID="mysql:mysql-connector-java:8.0.25"

inherit java-pkg-2 java-pkg-simple

DESCRIPTION="JDBC Type 4 driver for MySQL"
HOMEPAGE="https://dev.mysql.com/doc/connector-j/en/"
SRC_URI="https://repo1.maven.org/maven2/mysql/mysql-connector-java/${PV}/mysql-connector-java-${PV}-sources.jar -> ${P}-sources.jar"

LICENSE="GPL-2-with-MySQL-FLOSS-exception"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"

# Common dependencies
# POM: mysql-connector-java-${PV}.pom.xml
# com.google.protobuf:protobuf-java:3.11.4 -> !!!groupId-not-found!!!

CDEPEND="dev-java/c3p0:0
dev-java/protobuf-java:0
dev-java/slf4j-api:0"
DEPEND=" ${CDEPEND}
>=virtual/jdk-1.8:* "
RDEPEND=" ${CDEPEND}
>=virtual/jre-1.8:* "
BDEPEND="app-arch/unzip"

DOCS=( META-INF/README )

S="${WORKDIR}"

JAVA_GENTOO_CLASSPATH="c3p0,protobuf-java,slf4j-api"

JAVA_SRC_DIR="com"
JAVA_RESOURCE_DIRS="res"

src_prepare() {
default
mkdir --parents "${JAVA_RESOURCE_DIRS}" || die
cp -r "${JAVA_SRC_DIR}" "META-INF" "${JAVA_RESOURCE_DIRS}"
find "${JAVA_RESOURCE_DIRS}" -type f -name '*.java' -exec rm -rf {} + || die
}

src_install() {
default
java-pkg-simple_src_install
}

0 comments on commit 95bc042

Please sign in to comment.