forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emulation/docker-bench-security: new package
This utility checks for best practices around deploying docker containers Package-Manager: Portage-2.3.6, Repoman-2.3.1
- Loading branch information
Showing
4 changed files
with
44 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST docker-bench-security-1.3.2.tar.gz 414608 SHA256 9054a7f48b6519aa618df64bf09429e6178ae4a7199164cb4db7b95f05e8df19 SHA512 7d271167584ff99fdaff15b1d303f1cedeb5888057437cc3bfae8260aff96f98d8a0173c4d4e5718bf8ee4e0ffe3ae0280f0026cf386ae32c38e8302159a2226 WHIRLPOOL 923ca76221cb1056daaa32e7d98326548fa6107a10b0325ad99687fad87df2b1fafde44c218459c2f33825f58e69ee36de62107765f0fd5f83c4e58348dcf24c |
24 changes: 24 additions & 0 deletions
24
app-emulation/docker-bench-security/docker-bench-security-1.3.2.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="Test for best practices around deploying docker containers" | ||
HOMEPAGE="https://github.com/docker/docker-bench-security" | ||
SRC_URI="https://github.com/docker/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="Apache-2.0" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
|
||
RDEPEND=">=app-emulation/docker-1.10" | ||
|
||
src_install() { | ||
dobin "${FILESDIR}/docker-bench-security" | ||
exeinto /usr/lib/${PN} | ||
doexe ${PN}.sh | ||
insinto /usr/lib/${PN} | ||
doins -r *lib.sh tests | ||
dodoc -r benchmark_log.png CONTRIBUTING.md distros docker-compose.yml \ | ||
Dockerfile MAINTAINERS README.md | ||
} |
7 changes: 7 additions & 0 deletions
7
app-emulation/docker-bench-security/files/docker-bench-security
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
#!/bin/sh | ||
if [ $(id -u) -ne 0 ]; then | ||
printf "%s\n" "This script must be run as root." | ||
exit 1 | ||
fi | ||
cd "$(dirname $0)/../lib/docker-bench-security" | ||
./docker-bench-security.sh |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>William Hubbs</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
The Docker Bench for Security is a script that checks for dozens of | ||
common best-practices around deploying Docker containers in production. | ||
</longdescription> | ||
</pkgmetadata> |