Skip to content

Commit

Permalink
net-dns/getdns: version bump 1.72.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.30, Repoman-3.0.3
Signed-off-by: Anthony G. Basile <[email protected]>
  • Loading branch information
blueness committed Aug 26, 2022
1 parent 2649387 commit 962f152
Show file tree
Hide file tree
Showing 2 changed files with 95 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/getdns/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST getdns-1.7.0.tar.gz 690885 BLAKE2B 25e81c01c5da0a5494dc25077257f8f98210b442b7ca65c895aa2a40af180e840aa53205ae84ed242cbd6c55f8830caf255db9d7f607dde39f118ab7494a7072 SHA512 d09b8bdd0b4a3df2d25b9689166226da83a5a7eb2c7436487dc637539ac6077624a4d66cf684c4e6c4911561872c6bd191af3afd90d275b1662e4c6c47773ef6
DIST getdns-1.7.2.tar.gz 702969 BLAKE2B 668a754200b816790f39a772d89c28e14bc5dbd041e07d9e53605ad44d63d6637078b66881c35dda62ed61622142797cc8f0041522e076cf551651fca688053a SHA512 6c4a75a4696c46ec8bd9e9659a93fd81f3490b43da28a4c95f99a766027c7588fc493a8ac51563afb8f975c0e5b77d5ea67014d80e78ee2bb17fba1d1073d19f
94 changes: 94 additions & 0 deletions net-dns/getdns/getdns-1.7.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,94 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

_SRCURI_P="${P/%_beta1/-beta.1}"

inherit cmake fcaps systemd tmpfiles

DESCRIPTION="Modern asynchronous DNS API"
HOMEPAGE="https://getdnsapi.net/"
SRC_URI="https://getdnsapi.net/releases/${_SRCURI_P//./-}/${_SRCURI_P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples +getdns-query +getdns-server-mon gnutls +idn libev libevent libuv static-libs stubby test +unbound"

S="${WORKDIR}/${_SRCURI_P}"

# https://bugs.gentoo.org/661760
# https://github.com/getdnsapi/getdns/issues/407
# (As of 1.7.0, seems to need network)
RESTRICT="test"
#RESTRICT="!test? ( test )"

DEPEND="
dev-libs/libbsd
dev-libs/libyaml
dev-libs/openssl:=
idn? ( net-dns/libidn2:= )
gnutls? (
net-libs/gnutls:0=[dane,openssl]
dev-libs/nettle:0=
)
libev? ( dev-libs/libev:= )
libevent? ( dev-libs/libevent:= )
libuv? ( dev-libs/libuv:= )
test? ( dev-libs/check )
>=net-dns/unbound-1.5.9:=
"
RDEPEND="
${DEPEND}
stubby? (
acct-group/stubby
acct-user/stubby
sys-libs/libcap
)
"
BDEPEND="
doc? ( app-doc/doxygen )
"

PATCHES=(
"${FILESDIR}/${PN}-1.4.2-stubby.service.patch"
)

src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_RUNSTATEDIR=/var/run/stubby
-DBUILD_DOXYGEN=$(usex doc)
-DBUILD_GETDNS_QUERY=$(usex getdns-query)
-DBUILD_GETDNS_SERVER_MON=$(usex getdns-server-mon)
-DBUILD_STUBBY=$(usex stubby)
-DENABLE_STATIC=$(usex static-libs)
-DBUILD_TESTING:BOOL=$(usex test)
-DENABLE_UNBOUND_EVENT_API=$(usex unbound)
-DUSE_GNUTLS=$(usex gnutls)
-DUSE_LIBEV=$(usex libev)
-DUSE_LIBEVENT2=$(usex libevent)
-DUSE_LIBIDN2=$(usex idn)
-DUSE_LIBUV=$(usex libuv)
)
cmake_src_configure
}

src_install() {
cmake_src_install
if use stubby; then
newinitd "${FILESDIR}"/stubby.initd-r2 stubby
newconfd "${FILESDIR}"/stubby.confd-r1 stubby
insinto /etc/logrotate.d
newins "${FILESDIR}"/stubby.logrotate stubby
systemd_dounit "${S}"/stubby/systemd/stubby.service
dotmpfiles "${S}"/stubby/systemd/stubby.conf
fi
}

pkg_postinst() {
if use stubby; then
fcaps cap_net_bind_service=ei usr/bin/stubby
tmpfiles_process stubby.conf
fi
}

0 comments on commit 962f152

Please sign in to comment.