forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
media-libs/libzen: version bump to 0.4.35
- Loading branch information
Showing
2 changed files
with
67 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST libzen_0.4.34.tar.bz2 119347 SHA256 83774fe093bd14fb72da9c537021a8ffc3f6ff952a1401cd6f91de6628ac790a SHA512 46a2457b72c5f8b585eaec9ca99405cc795ea96174494651ccb57c0ef9317f1b7632992bb1d430fe5e62cab9849f102effd3558e8f5b0c36bc9515ed81c4e386 WHIRLPOOL 9817dfc03af8c47dbde1b808c658b3523fc9494d875629b83f49677c6d4e5314b016ce3a467c4bcf5f65fb32052659fd1b9b4499e9705722096ae082ecbe52e8 | ||
DIST libzen_0.4.35.tar.bz2 120440 SHA256 7e21978d425801c498fcc4d5043c75b0bc3e4721618a180728fb39c71e8b4189 SHA512 0f9faa7975c91a1bd3e0cf47881fc3d86f32bc81ac1b371f8708c9187ca126a1240049ee6d267faa5d9b24b9a7f2066990796f7b8386dbb574c5e967c5889f1d WHIRLPOOL 81bfbb4f039a2acb82b4804a99a124e604c60829204ba2489b4010d281c46638521b5a5ee98b8f98c268818915e4d6201444e2fc61cd4519e92a416061e59fca |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,66 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit autotools multilib eutils | ||
|
||
MY_PN="ZenLib" | ||
DESCRIPTION="Shared library for libmediainfo and mediainfo" | ||
HOMEPAGE="https://github.com/MediaArea/ZenLib http://mediaarea.net/mediainfo/" | ||
SRC_URI="http://mediaarea.net/download/source/${PN}/${PV}/${P/-/_}.tar.bz2" | ||
|
||
LICENSE="ZLIB" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="doc static-libs" | ||
|
||
DEPEND="virtual/pkgconfig | ||
doc? ( app-doc/doxygen )" | ||
|
||
S=${WORKDIR}/${MY_PN}/Project/GNU/Library | ||
|
||
src_prepare() { | ||
default | ||
sed -i 's:-O2::' configure.ac || die | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf \ | ||
--enable-unicode \ | ||
--enable-shared \ | ||
$(use_enable static-libs static) | ||
} | ||
|
||
src_compile() { | ||
default | ||
|
||
if use doc ; then | ||
cd "${WORKDIR}"/${MY_PN}/Source/Doc | ||
doxygen Doxyfile || die | ||
fi | ||
} | ||
|
||
src_install() { | ||
default | ||
|
||
# remove since the pkgconfig file should be used instead | ||
rm "${D}"/usr/bin/libzen-config | ||
|
||
insinto /usr/$(get_libdir)/pkgconfig | ||
doins ${PN}.pc | ||
|
||
for x in ./ Format/Html Format/Http HTTP_Client ; do | ||
insinto /usr/include/${MY_PN}/${x} | ||
doins "${WORKDIR}"/${MY_PN}/Source/${MY_PN}/${x}/*.h | ||
done | ||
|
||
dodoc "${WORKDIR}"/${MY_PN}/History.txt | ||
if use doc ; then | ||
docinto html | ||
dodoc "${WORKDIR}"/${MY_PN}/Doc/* | ||
fi | ||
|
||
prune_libtool_files | ||
} |