Skip to content

Commit

Permalink
dev-lang/ekopath: Snapshot bump
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
  • Loading branch information
mgorny committed Oct 11, 2015
1 parent 66a9159 commit 96a63c9
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/ekopath/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST ekopath-2015-08-09-installer.run 58521154 SHA256 7ecd2a03012e36851f69ab35f1
DIST ekopath-2015-08-11-installer.run 59150939 SHA256 31f491e3744257ae87b735be418287ac4530bf525cd4c61fdb0f2438f0600e4b SHA512 ada2dc774247e5ea76f35f6f9311d58d99ec599e41befc0820650affae88be6916a2dd50bf9e67e4920db2ab16fc185fb088e523c1abc75ed7bfc5ec261e0eb1 WHIRLPOOL 721deca6bb973bf64219709cd0fc95907a2c5cfb447a295e45410939f700244197fd2a382ae537a847c10368af44fcbc538ddc9529769cfa4613eab118362df7
DIST ekopath-2015-09-10-installer.run 57138157 SHA256 fd4eca09107b9967ba01e508098c00fddbb809ba637e42aa1bb4b7518e947394 SHA512 67f99cbf74e1840de3ee4f1da810031b9e67c1ecfd7de6ff56c8303bdcdf6d9eedbb9eab975d7a6bb1ccbb3c5a65a3f60c7219f2321bd2eb4949f04979142148 WHIRLPOOL d41c1ca250b81d584d4f088ad8b03fe975bbb9fe5d6ef50c2d501904e0f187cefaf41e772c0cbd835106c1fed995a7e754a875fd621314b28bdde19a2a14fb88
DIST ekopath-2015-09-21-installer.run 57536286 SHA256 a3aab3f1cc018222644a7d4e10d0ebe68d38626074e95638d54ae9b690721332 SHA512 3a98635f233055a81435f6dd0044f13efe7b97a7554ca5c9b50586b74a3e848076842ce0bc04c07283e8cbf92bf21fcc9b4ca36888c379ddd3190364fea9bc90 WHIRLPOOL 3bd6debddb33776ca85951a942ff87a869ca6ee0defcd493750f1682dc0f769f5c1e44820510323cd7a983b486cab07b34a955d65b890fe3d0e36171036e678d
DIST ekopath-2015-10-10-installer.run 57723481 SHA256 0cd16e8c70d3e7938474e8885a721f0e50871a01a742b7a653dd1e6791e32baf SHA512 a4e33475b0fce0f3e9e0b744f1ba898983223cee15861491b6f7c3584c381b25c922fc17a7fd759f609f8c73ecbfbd53eeaaea38ddd9151d1cd7e46d0f1cf883 WHIRLPOOL 45744d16e34297ba47bc028382f1dc29cf0611cbff76a179640629ea89526818b4580c63e69d54541bbe915963c761b9abfe809ee2854be58e73ad80bc4e7143
74 changes: 74 additions & 0 deletions dev-lang/ekopath/ekopath-6.0.551_p20151010.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit versionator multilib pax-utils

MY_PV=$(get_version_component_range 1-3)
DATE=$(get_version_component_range 4)
DATE=${DATE#p}
DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6}
INSTALLER=${PN}-${DATE}-installer.run

DESCRIPTION="PathScale EKOPath Compiler Suite"
HOMEPAGE="http://www.pathscale.com/ekopath-compiler-suite"
SRC_URI="http://c591116.r16.cf2.rackcdn.com/${PN}/nightly/Linux/${INSTALLER}"

LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

DEPEND="!!app-arch/rpm"
RDEPEND=""

RESTRICT="bindist mirror"

QA_PREBUILT="
opt/${PN}/lib/${MY_PV}/x8664/*
opt/${PN}/bin/*"

S="${WORKDIR}"

src_unpack() {
cp "${DISTDIR}/${INSTALLER}" "${S}/" || die
chmod +x "${S}/${INSTALLER}" || die
}

src_prepare() {
cat > 99${PN} <<-EOF
PATH=${EROOT%/}/opt/${PN}/bin
ROOTPATH=${EROOT%/}/opt/${PN}/bin
LDPATH=${EROOT%/}/opt/${PN}/lib:${EROOT%/}/opt/${PN}/lib/${MY_PV}/x8664/64
MANPATH=${EROOT%/}/opt/${PN}/docs/man
EOF
}

src_install() {
# EI_PAX marking is obsolete and PT_PAX breaks the binary.
# We must use XT_PAX to run the installer.
if [[ ${PAX_MARKINGS} == "XT" ]]; then
pax-mark m "${INSTALLER}"
fi

./"${INSTALLER}" \
--prefix "${ED%/}/opt/${PN}" \
--mode unattended || die

if [[ ! -d ${ED%/}/opt/${PN}/lib/${MY_PV} ]]; then
local guess
cd "${ED%/}/opt/${PN}/lib" && guess=( * )

if [[ ${guess[@]} ]]; then
die "Incorrect release version in PV, guessing it should be: ${guess[*]}"
else
die "No libdir installed"
fi
fi
[[ -x ${ED%}/opt/${PN}/bin/pathcc ]] || die "No pathcc executable was installed, your hardware is unsupported most likely"

rm -r "${ED}/opt/${PN}"/uninstall* || die
doenvd 99${PN}
}

0 comments on commit 96a63c9

Please sign in to comment.