forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-lua/luasec: bump to 0.5.1 for libressl
- Loading branch information
Showing
3 changed files
with
42 additions
and
2 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST luasec-0.4.1.tar.gz 28646 SHA256 9a9ea9f23044d41be29aea3de1bd795118a29e7311ea4c55fe1f0bc1c74a448b SHA512 bc934e952294ec45c9c8cfb70f68ebcd415b241d4af8dbf649016a7d14d7da5380d12cbf490560425235168f2c5abbbcd48192068a4e8e6bf523c92cfbf604d9 WHIRLPOOL 90ebad1e0f9fba88bbfe3832ef61cf1daab3cf3694bb0d4466772a24ad103f737737af93df77cc6aea04a98fb9ad0cdf0dcf6f2a09667643a8cabbd6030e7d49 | ||
DIST luasec-0.4.1_p20130620.tar.gz 45297 SHA256 8bb3e8c5c3a4980f027b7ab41d5a08a2d44834e4230bcb6a2638ba4a7a3dc53f SHA512 914ae2adf7ce48c78d972ae5cbe2b52cbd42083cbe98063c36bd52af52b3bdec4cb389b8599928b2703436fc8eaf70de3212def0adaf936c7bbedf650f9c8c4e WHIRLPOOL 7a7c8e43ae846a8351c39a1dbfaab091a9d12c197538413137c0de807da6d20b894155fd9ec1f4bdefd7090a7b7cdb7ef195165870a6b5addd1ad66ad7208d11 | ||
DIST luasec-0.5.1.tar.gz 46820 SHA256 6d5c5f8e0521f3194668d9a839774e079e2fd5c45b15538dc7b8cacc56719406 SHA512 c7c92c79d0ec3e12b69f88d810a19397eaf570957d1f13b9695ee435cb6f0f9c31f5bc20a7252aac93d18eed98a5d3fc8a181cd85845a704e469055f215609a8 WHIRLPOOL 69bc39c8f91a0b4be9fbe9a6531e110cabb25b2f09a1588510a5e993d1f6da7f93154647b8265ee028f4dbc45f65febf0066c3bbb62a59fd3be2761fe5c70798 | ||
DIST luasec-0.5.tar.gz 46738 SHA256 6480598f7492ac479b6b608b5fb1488226bfa6ef675e29f6b24dbe9099083523 SHA512 fcf88f2566952c4d12be95531991180a1f3bd60f7dda41997f93c80ccc8d9dfd44b00e3330a07e451489dc9cd0640f7841101c10867e270608187df78549fe2f WHIRLPOOL 46d87a3ee3a6cf1413696c1dee0ea77913e6ffce94789e36f28ca5b2ec737cd1d2c81852c5b96958dcf53c22eee20d24102fb3ceea923692dbfb848b2fc52215 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,39 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit multilib toolchain-funcs | ||
|
||
DESCRIPTION="Lua binding for OpenSSL library to provide TLS/SSL communication" | ||
HOMEPAGE="https://github.com/brunoos/luasec http://www.inf.puc-rio.br/~brunoos/luasec/" | ||
SRC_URI="https://github.com/brunoos/luasec/archive/${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="amd64 arm x86" | ||
IUSE="libressl" | ||
|
||
RDEPEND=" | ||
>=dev-lang/lua-5.1:0[deprecated] | ||
dev-lua/luasocket | ||
!libressl? ( dev-libs/openssl:0 ) libressl? ( dev-libs/libressl:= )" | ||
DEPEND="${RDEPEND} | ||
virtual/pkgconfig" | ||
|
||
S=${WORKDIR}/${PN}-${P} | ||
|
||
src_prepare() { | ||
sed -i -e "s#^LUAPATH.*#LUAPATH=$(pkg-config --variable INSTALL_LMOD lua)#"\ | ||
-e "s#^LUACPATH.*#LUACPATH=$(pkg-config --variable INSTALL_CMOD lua)#" Makefile || die | ||
sed -i -e "s/-O2//" src/Makefile || die | ||
lua src/options.lua -g /usr/include/openssl/ssl.h > src/options.h || die | ||
} | ||
|
||
src_compile() { | ||
emake \ | ||
CC="$(tc-getCC)" \ | ||
LD="$(tc-getCC)" \ | ||
linux | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters