Skip to content

Commit

Permalink
app-misc/linuxspa: EAPI 6 bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.1
  • Loading branch information
Amynka committed Aug 20, 2017
1 parent 29d1196 commit 96c3f02
Showing 1 changed file with 40 additions and 0 deletions.
40 changes: 40 additions & 0 deletions app-misc/linuxspa/linuxspa-0.7.1-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit eutils toolchain-funcs

MY_PN="LinuxSPA"
DESCRIPTION="Linux Serial Protocol Analyser"
HOMEPAGE="https://sourceforge.net/projects/serialsniffer/"
SRC_URI="mirror://sourceforge/serialsniffer/${MY_PN}-${PV}.tgz"
LICENSE="GPL-2"

SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

S="${WORKDIR}/${MY_PN}"

PATCHES=( "${FILESDIR}/${P}-compile-fix.patch" )

src_prepare() {
default
sed -i Makefile \
-e 's| -o | $(LDFLAGS)&|g' \
|| die "sed Makefile"
}

src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS} -Wall" \
LDFLAGS="${LDFLAGS}"
}

src_install() {
dobin LinuxSPA std232
dodoc ASCII_Filter.txt BCircuit.txt LinuxSPA.png READING_Materials.txt \
README TODO connector-1a.ps connector-2a.ps cooked.file raw.file
}

0 comments on commit 96c3f02

Please sign in to comment.