Skip to content

Commit

Permalink
dev-python/setuptools: Bump to 41.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Apr 6, 2019
1 parent 0d714fa commit 96ca174
Show file tree
Hide file tree
Showing 2 changed files with 74 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/setuptools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST setuptools-40.6.3.zip 839328 BLAKE2B ddc87213439ce2ad96ba54218bd5b3e41a7c31
DIST setuptools-40.7.3.zip 842920 BLAKE2B 53b5845f157d088fa0848384770f185b2daf8f1bc0304e8d5ab3eb5cae44a42133e7cf2f655e95be351733760ed401d55e3717c4a1257c77644796c08cbe67f6 SHA512 fb61e4d7ae620684b128bd60112938a4a9721a82ed3aa4daa774837a2db60e989d608ce2ba7f51393f412b78244d6f4c8f1025416b137d8ce01a2c0375ffec65
DIST setuptools-40.8.0.zip 845071 BLAKE2B a76b92a7e3a5cd87d74f3ff5f49fe4c6b2a1f0c5cc3b04219f6f773585be479ec5d092185129ada1fe5c5ef62714687beb3a316a6d50b559e9224aed468aef24 SHA512 f14976a76bff74b7494d44fcfffa511de0d142b4d308fcbf87b34c31c51491102e152acc11a383c5f6b693d1b18eb119c5186ca23deb12b2bbf186794b062868
DIST setuptools-40.9.0.zip 847572 BLAKE2B 1ef3f05d747a67395f705ad46bf066f400c9a5ad97efe73175e72eb9091c929cb61a526da1206f431a4e054939e0fd2b2a841a892c6cc76a6116cf781112b472 SHA512 2d278ef162139dfb1dd3640154ae3db755ff5c2285810c85b0452d12e3f3cb199e3f1a1ec7cc43a377d42cd4f86e97e2c773d9f0a3bef8dc1acbf31e6f61033f
DIST setuptools-41.0.0.zip 848208 BLAKE2B 8d92cfb25f4ac1d0fd209b524693d66eca8fbc43b0ae4bf81343dd97820fd3b0572c8994c6ed1ee8c18e86a7eb4a6154dba53d81da081c950fa1ae1b61e023cf SHA512 e0f310368c50d954c8b0499ca2ea0e969e82515d0526b854c47d74cf6bb5af505cc522d926a346ab636163af6a85d1b40658c1701e759fbdf36f817af79ba7b1
73 changes: 73 additions & 0 deletions dev-python/setuptools/setuptools-41.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,73 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
PYTHON_REQ_USE="xml(+)"

inherit distutils-r1

if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/pypa/setuptools.git"
inherit git-r3
else
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi

DESCRIPTION="Collection of extensions to Distutils"
HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"

LICENSE="MIT"
SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"

RDEPEND="
"
DEPEND="${RDEPEND}
app-arch/unzip
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pip[${PYTHON_USEDEP}]
>=dev-python/pytest-3.7.0[${PYTHON_USEDEP}]
<dev-python/pytest-4
dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
dev-python/wheel[${PYTHON_USEDEP}]
virtual/python-futures[${PYTHON_USEDEP}]
)
"
PDEPEND="
>=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]"

# Force in-source build because build system modifies sources.
DISTUTILS_IN_SOURCE_BUILD=1

DOCS=( {CHANGES,README}.rst docs/{easy_install.txt,pkg_resources.txt,setuptools.txt} )

python_prepare_all() {
if [[ ${PV} == "9999" ]]; then
python_setup
${EPYTHON} bootstrap.py || die
fi

# disable tests requiring a network connection
rm setuptools/tests/test_packageindex.py || die

# don't run integration tests
rm setuptools/tests/test_integration.py || die

distutils-r1_python_prepare_all
}

python_test() {
# test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
# It tries to sandbox the test in a tempdir
HOME="${PWD}" pytest -vv ${PN} || die "Tests failed under ${EPYTHON}"
}

python_install() {
export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
distutils-r1_python_install
}

0 comments on commit 96ca174

Please sign in to comment.