Skip to content

Commit

Permalink
sci-geosciences/gpxsee: bump to 5.17
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.41, Repoman-2.3.9
  • Loading branch information
Andrey Grozin committed Sep 3, 2018
1 parent b27e20f commit 96ddbd1
Show file tree
Hide file tree
Showing 2 changed files with 78 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-geosciences/gpxsee/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gpxsee-5.14.tar.gz 3155455 BLAKE2B 6180efa345532c99a655b80b6052e6646d4b8bcf5b7feda1eec6f0c73ca63a21cf6ab7efd29e297d35e2cd5ab8cd73204864f1db0e9417107b59bc29f8982d3e SHA512 0fa666b999bb6990a3e78087053f9647c023a21b2bbec870fffc4fe1df3982e06beb294231340c4a0a006d06a1c136f94a09724ffa76758c1246d79f3077b075
DIST gpxsee-5.17.tar.gz 3831253 BLAKE2B 297dc940a373a302e93b647b386813d1d0d96ac3d01937f84d8bb79239be492b358351b498743981c046a86349b5036d4448288e7cb113eae42383b1f3ed64ed SHA512 260af8d80df5d4239a4ad6c32154871f663c167f6dc697a4cbc7127d29e8752c401720697ba463647852d4179cd484e871645385baad277f3512e74159a2016e
77 changes: 77 additions & 0 deletions sci-geosciences/gpxsee/gpxsee-5.17.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

PLOCALES="cs de fi fr pl ru sv"
inherit qmake-utils l10n xdg-utils gnome2-utils

MY_PN="GPXSee"
MY_P="${MY_PN}-${PV}"

DESCRIPTION="A viewer and analyzer that supports gpx, tcx, kml, fit, igc and nmea files"
HOMEPAGE="http://www.gpxsee.org/"
SRC_URI="https://github.com/tumic0/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND="dev-qt/qtwidgets:5
dev-qt/qtgui:5
dev-qt/qtprintsupport:5
dev-qt/qtnetwork:5
dev-qt/qtcore:5"
DEPEND="${RDEPEND}
dev-qt/linguist-tools:5"

S="${WORKDIR}/${MY_P}"

src_prepare() {
default

l10n_find_plocales_changes lang "${PN}_" '.ts'

rm_ts() {
sed -e "s|lang/gpxsee_${1}.ts||" -i gpxsee.pro
}

l10n_for_each_disabled_locale_do rm_ts
}

src_compile() {
lrelease gpxsee.pro
eqmake5 gpxsee.pro
emake
}

src_install() {
local lang
newbin ${MY_PN} ${PN}
dodoc README.md
insinto /usr/share/${PN}
doins -r pkg/maps pkg/csv

insinto /usr/share/${PN}/translations
for lang in lang/*.qm; do
[ -f "${lang}" ] && doins "${lang}"
done

insinto /usr/share/applications
doins pkg/${PN}.desktop
insinto /usr/share/mime/packages
doins pkg/${PN}.xml
insinto /usr/share/pixmaps
doins icons/${PN}.png
}

pkg_postinst() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_mimeinfo_database_update
gnome2_icon_cache_update
}

0 comments on commit 96ddbd1

Please sign in to comment.