forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gnome-extra/gnome-shell-extension-bing-wallpaper: add 48
Signed-off-by: Pacho Ramos <[email protected]>
- Loading branch information
Showing
2 changed files
with
57 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,4 @@ | ||
DIST gnome-shell-extension-bing-wallpaper-45-gnome45.patch 73697 BLAKE2B 5d92c6ff899a4b873dc989cc6784dd6af092b1bf27a124be9e9fb65b0d4e19b1729ace79cdfaefd50088396dd535b20016da81ea47450b99869391e34f7846e0 SHA512 91fbce811f6299f7bf4caac5630936a714482ba466c8557e87450f11e39bb10b1d3662352e28f4ba2981426711722814be36fe6d0a0ec25bf25020797c831508 | ||
DIST gnome-shell-extension-bing-wallpaper-45.tar.gz 5410536 BLAKE2B bf0a8c7ae8fc421ba9a9cd88cf689b18336c3e25e0eb5627e600e4d8e2fb0ace1c7b867e189aef8fa2e3f2a7cc2e7164636e712a4ad0e6cf3b54b4c9428a96d8 SHA512 e82bb69745f06c83d76a7faad0c777b7b77b69b39a31cf7845593c861b45cb571a5183423efbbf05cfdb0e2b43f205160e903de65d545d98df0ccd43710b00de | ||
DIST gnome-shell-extension-bing-wallpaper-46.tar.gz 5408142 BLAKE2B cb3a1145bca49b9fe77e44ca7a61eca70c6cc8568970092a1a178d6b93cf8a951f22f6e28f7f215c99a1d657b616a7209a201bf2523be63a52c081406b8af8c9 SHA512 d18c88d077c55cc4bdd1277d1ab1ff99f91ab02625290364f8cc4c696def3820366200af11307b284c68825105ec8b01c22ce32c0ec43d348443b4b5366c8d9d | ||
DIST gnome-shell-extension-bing-wallpaper-48.tar.gz 5407779 BLAKE2B bf3a10389ae5d2bdaab11c9927ca0227e453a25d9719a903dfdf136d3fe4746efc88d44fa1f935ef40e401deea2a6fffa45ded56f8aa4fe06e2ebb55c0792c74 SHA512 27a46bb2aca38c7fde5f793ca1190ec24cf363e2b01eb7fe79d19dbe2cadf269e709c5e5a090a4d966d9359cbd20f035f10b7bfdcc34ea39b8aa8346e89663e0 |
56 changes: 56 additions & 0 deletions
56
...extra/gnome-shell-extension-bing-wallpaper/gnome-shell-extension-bing-wallpaper-48.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,56 @@ | ||
# Copyright 1999-2023 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
inherit gnome2-utils | ||
|
||
DESCRIPTION="Change your wallpaper daily to the bing.com background image" | ||
HOMEPAGE="https://github.com/neffo/bing-wallpaper-gnome-extension" | ||
SRC_URI="https://github.com/neffo/bing-wallpaper-gnome-extension/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-3" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
RDEPEND=" | ||
dev-libs/glib:2 | ||
app-eselect/eselect-gnome-shell-extensions | ||
>=gnome-base/gnome-shell-45 | ||
net-libs/libsoup:3.0 | ||
" | ||
DEPEND="" | ||
BDEPEND="" | ||
|
||
S="${WORKDIR}/bing-wallpaper-gnome-extension-${PV}" | ||
extension_uuid="[email protected]" | ||
|
||
PATCHES=( | ||
# https://github.com/neffo/bing-wallpaper-gnome-extension/issues/113 | ||
"${FILESDIR}/${PN}-44-unlock-screen.patch" | ||
) | ||
|
||
src_install() { | ||
einstalldocs | ||
rm -f README.md LICENSE || die | ||
insinto /usr/share/glib-2.0/schemas | ||
doins schemas/*.xml | ||
rm -rf schemas | ||
insinto /usr/share/gnome-shell/extensions/"${extension_uuid}" | ||
doins -r * | ||
} | ||
|
||
pkg_preinst() { | ||
gnome2_schemas_savelist | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_schemas_update | ||
ebegin "Updating list of installed extensions" | ||
eselect gnome-shell-extensions update | ||
eend $? | ||
} | ||
|
||
pkg_postrm() { | ||
gnome2_schemas_update | ||
} |