Skip to content

Commit

Permalink
media-gfx/pqiv: add archive use flag and fix backend loading (bug #60…
Browse files Browse the repository at this point in the history
…3506)
  • Loading branch information
radhermit committed Feb 23, 2017
1 parent 9be5d9b commit 97034d0
Show file tree
Hide file tree
Showing 2 changed files with 80 additions and 0 deletions.
3 changes: 3 additions & 0 deletions media-gfx/pqiv/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -12,4 +12,7 @@
</maintainer>
<remote-id type="github">phillipberndt/pqiv</remote-id>
</upstream>
<use>
<flag name="archive">Enable support for images in archives and cbX comic book files</flag>
</use>
</pkgmetadata>
77 changes: 77 additions & 0 deletions media-gfx/pqiv/pqiv-2.7.4-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,77 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6
inherit linux-info flag-o-matic toolchain-funcs fdo-mime

DESCRIPTION="Modern rewrite of Quick Image Viewer"
HOMEPAGE="https://github.com/phillipberndt/pqiv http://www.pberndt.com/Programme/Linux/pqiv/"
SRC_URI="https://github.com/phillipberndt/pqiv/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="archive ffmpeg imagemagick kernel_linux libav pdf postscript"

RDEPEND="
>=dev-libs/glib-2.8:2
>=x11-libs/cairo-1.6
x11-libs/gtk+:3
archive? ( app-arch/libarchive:0= )
ffmpeg? (
!libav? ( media-video/ffmpeg:0= )
libav? ( media-video/libav:0= )
)
imagemagick? ( media-gfx/imagemagick:0= )
pdf? ( app-text/poppler:0= )
postscript? ( app-text/libspectre:0= )
"
DEPEND="${RDEPEND}
virtual/pkgconfig"

pkg_setup() {
if use kernel_linux; then
CONFIG_CHECK="~INOTIFY_USER"
linux-info_pkg_setup
fi
}

src_prepare() {
default
sed -i \
-e "s:/lib/:/$(get_libdir)/:g" \
GNUmakefile || die

# bug #603506
append-ldflags -Wl,--disable-new-dtags
}

src_configure() {
local backends="gdkpixbuf"
use archive && backends="${backends},archive,archive_cbx"
use ffmpeg || use libav && backends="${backends},libav"
use imagemagick && backends="${backends},wand"
use pdf && backends="${backends},poppler"
use postscript && backends="${backends},spectre"

./configure \
--backends-build=shared \
--backends=${backends} \
--prefix="${EPREFIX}/usr" \
--destdir="${ED}" \
|| die
}

src_compile() {
tc-export CC
emake VERBOSE=1 CFLAGS="${CFLAGS}"
}

pkg_postinst() {
fdo-mime_desktop_database_update
}

pkg_postrm() {
fdo-mime_desktop_database_update
}

0 comments on commit 97034d0

Please sign in to comment.