forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-crypt/yubikey-manager-qt: Initial version
Package-Manager: Portage-2.3.6, Repoman-2.3.2
- Loading branch information
Showing
3 changed files
with
49 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST yubikey-manager-qt-0.3.0_p20170316.tar.gz 174053 SHA256 69144073666e7ef4e8273fb1dd93b452a6091a5b9beabd2f3de41cce6d0b6668 SHA512 9280aeb242ab3e9f66b297d8cdab0b5f16bb966469932501bcfaf8d084d2db8f1c566ebdc82a4fb3f80ab196b946982f723a1cf8a36736c8dd874757b94c2472 WHIRLPOOL 6ae4c54242a83553d58cd78a24b2e99b73df004af0d8008f34a3ba635672fd2ef2b587ad3301aa1fdd3d619014704abdfe512b3d6ad9c55ae4f4f4b33aceb21b |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>Manuel Rüger</name> | ||
</maintainer> | ||
</pkgmetadata> |
40 changes: 40 additions & 0 deletions
40
app-crypt/yubikey-manager-qt/yubikey-manager-qt-0.3.0_p20170316.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
PYTHON_COMPAT=( python3_{4,5,6} ) | ||
|
||
inherit qmake-utils python-single-r1 vcs-snapshot | ||
|
||
DESCRIPTION="Cross-platform application for configuring any YubiKey over all USB transports" | ||
HOMEPAGE="https://developers.yubico.com/yubikey-manager-qt https://github.com/Yubico/yubikey-manager-qt" | ||
COMMIT="700095c13f9da2dc74d338687f48196324f15c00" | ||
SRC_URI="https://github.com/Yubico/yubikey-manager-qt/archive/${COMMIT}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="BSD-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
DEPEND="app-crypt/yubikey-manager[${PYTHON_USEDEP}] | ||
dev-python/pyotherside[${PYTHON_USEDEP}] | ||
dev-qt/qtsingleapplication[qt5] | ||
dev-qt/qtdeclarative:5 | ||
dev-qt/qtwidgets:5" | ||
RDEPEND="${DEPEND}" | ||
|
||
src_prepare() { | ||
default | ||
rm -rf vendor ykman-gui/vendor || die | ||
sed -i -e "s/ykman-cli//" ${PN}.pro || die | ||
sed -i -e "/qtsingleapplication.pri/d" -e "/CONFIG += c++11/a CONFIG += qtsingleapplication" -i ykman-gui/ykman-gui.pro || die | ||
} | ||
|
||
src_configure() { | ||
eqmake5 | ||
} | ||
|
||
src_install() { | ||
emake install INSTALL_ROOT="${D}" | ||
} |