Skip to content

Commit

Permalink
net-misc/youtube-dl: Version 2018.01.27.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.20, Repoman-2.3.6
  • Loading branch information
Jeroen Roovers committed Jan 30, 2018
1 parent a5de8f2 commit 97e9d2e
Show file tree
Hide file tree
Showing 2 changed files with 116 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/youtube-dl/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST youtube-dl-2017.03.16.tar.gz 2631620 BLAKE2B 2aff8710a296140a4329b0f8e7f575
DIST youtube-dl-2017.11.15.tar.gz 2834012 BLAKE2B fd93e3923f99874be58681a886c09e31ac10063975ab636badf27e59b44743c72cddf05e3a431c49ffd0f7b40f9b005f4d90feff85d4ca889dee80833300b076 SHA512 e10c0d53db7fdfb02610b53f54046c0a9354b305ba05c5d00a43649a283a6449263f66ff56171d52cf18f906c6aeccc25dc48ea708b4b1bb2b8323b937abca96
DIST youtube-dl-2018.01.18.tar.gz 2885167 BLAKE2B 2615c70fbc119c0d07cc797e9c36ea9a751a6603da91ff6822440cec0ccf924ac9cf76b08cb2d2975fa6572473d41cd898f71ceb43529aa27def1a15b7e86367 SHA512 8770b82b61b9038eccdbfe1391d85b7ac8edd8ff1258259a8955ca12b98559b889b0d98e8d39df1f27e7c7dd92cd7ee303af15de19eedfa74206d2a66155c12b
DIST youtube-dl-2018.01.21.tar.gz 2888153 BLAKE2B 8e8dc011438b26acc49daf9564b20a3f037834f90f906a2e04eb2ba67d657e96f1dd7dcba363153d6a2b36542b7236454663db10c5955009b9687b55263e5c0c SHA512 58bb02918aa0ec04f30ab4acb4fc0f130fd0b991084331f4b587c87f0e08db678ff588e92afea44491d275e909aee4bd73b7f941cc0c0acdbc2bad9ba94bb15b
DIST youtube-dl-2018.01.27.tar.gz 2893288 BLAKE2B 8c0c5c09d49d4d729c51cc706b94b3507f97d14591f76325bbe8c0174b7b485267067a8f11f788ad738cf890b1917ce746f5613b240f8f754d902f95c21d3705 SHA512 dfe43d855ed6162542531a471f3683e6fd0c3aa094f736a5a53b4efc298106e609787063380d112a2cd0888791e677c11e70fbc90aad096cbbc0aa82442eecff
115 changes: 115 additions & 0 deletions net-misc/youtube-dl/youtube-dl-2018.01.27.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
inherit bash-completion-r1 distutils-r1 readme.gentoo-r1

DESCRIPTION="Download videos from YouTube.com (and more sites...)"
HOMEPAGE="https://rg3.github.com/youtube-dl/"
SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"

LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
IUSE="+offensive test"

RDEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
"
DEPEND="
${RDEPEND}
test? ( dev-python/nose[coverage(+)] )
"

S="${WORKDIR}/${PN}"

python_prepare_all() {
if ! use offensive; then
sed -i -e "/..version../s|'$|+gentoo.no.offensive.sites'|g" \
youtube_dl/version.py || die
# these have single line import statements
local xxx=(
alphaporno anysex behindkink camwithher chaturbate eporner
eroprofile extremetube foxgay goshgay hellporno hentaistigma
hornbunny keezmovies lovehomeporn mofosex myvidster porn91 porncom
pornflip pornhd pornotube pornovoisines pornoxo ruleporn sexu
slutload spankbang spankwire sunporno thisav tube8 vporn
watchindianporn xbef xnxx xtube xvideos xxxymovies youjizz youporn
)
# these have multi-line import statements
local mxxx=(
drtuber fourtube motherless pornhub redtube tnaflix xhamster
)
# do single line imports
sed -i \
-e $( printf '/%s/d;' ${xxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

# do multiple line imports
sed -i \
-e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
youtube_dl/extractor/extractors.py \
|| die

sed -i \
-e $( printf '/%s/d;' ${mxxx[@]} ) \
youtube_dl/extractor/generic.py \
|| die

rm \
$( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
$( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
test/test_age_restriction.py \
|| die
fi

eapply_user

distutils-r1_python_prepare_all
}

src_compile() {
distutils-r1_src_compile
}

python_test() {
emake test
}

python_install_all() {
dodoc README.txt
doman ${PN}.1

newbashcomp ${PN}.bash-completion ${PN}

insinto /usr/share/zsh/site-functions
newins youtube-dl.zsh _youtube-dl

insinto /usr/share/fish/completions
doins youtube-dl.fish

distutils-r1_python_install_all

rm -r "${ED}"/usr/etc || die
rm -r "${ED}"/usr/share/doc/youtube_dl || die
}

pkg_postinst() {
elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
elog
elog "${PN} works fine on its own on most sites. However, if you want"
elog "to convert video/audio, you'll need avconf (media-video/libav) or"
elog "ffmpeg (media-video/ffmpeg). On some sites - most notably YouTube -"
elog "videos can be retrieved in a higher quality format without sound."
elog "${PN} will detect whether avconv/ffmpeg is present and"
elog "automatically pick the best option."

elog
elog "Videos or video formats streamed via RTMP protocol can only be"
elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
elog "Downloading MMS and RTSP videos requires either mplayer"
elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
}

0 comments on commit 97e9d2e

Please sign in to comment.