Skip to content

Commit

Permalink
sys-libs/talloc: Bump to version 2.1.4
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.23
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Oct 17, 2015
1 parent e496c6a commit 9825e96
Show file tree
Hide file tree
Showing 2 changed files with 86 additions and 0 deletions.
1 change: 1 addition & 0 deletions sys-libs/talloc/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST talloc-2.1.0.tar.gz 416097 SHA256 0701393882647f823503e3aa075bc67d75c194b376822377dae2d20f9130f08f SHA512 7bdc448c91211299edf16502d263362ac660d5123d8ea7bb2ed58af2231537e4f29da5384b8d5be10254a02b193520890e95a73d697c40eba09728a9b6d56d57 WHIRLPOOL d8593cba27f5d971acb39acacdbea70df5b80ed31288cf440a2ebeaca266e070deeea8322f4ba5682580f66044128f18dd6d76b735aa0670aed46f13f5a4e857
DIST talloc-2.1.2.tar.gz 423706 SHA256 230d78a3fca75a15ab0f5d76d7bbaeadd3c1e695adcbb085932d227f5c31838d SHA512 9bb3b8a1be663b63c03ec3336de2e4941052012357dacd0f4303ebb0c4d7f84fb7425bece114fda67167624ea417f57b33dfd5a8f373178c044f8270fecd596a WHIRLPOOL 464ead270ef6e315316505eb287eb8c3647d0807ace35a8b8f3fcf9697aeeac85ba652b56a5ae7a58d7eada7d2fd8cb33ee1032b912a7ee83eee74df8eadb349
DIST talloc-2.1.3.tar.gz 434093 SHA256 7aa5f75b22d4ef9c737b25515f2a2837ddc13014ff4ac6e58dd9e311f41f2cb0 SHA512 4ec350ab5d7e53c8ae816a3d722b10cce75552f1b3d6a31cc7aae13d6c5722d39a126702c8ebb4fa2f6b7908a6501e916e341e2b660080a6c8d22f70171862f6 WHIRLPOOL 143b733e4694b02b2c6319d1ee7017a54c0a60af5202ad764247aada0ada7a6fc95bcf08992dac4ae1396ed45106ad1102f09eece8b0f0304d32d965655c7c86
DIST talloc-2.1.4.tar.gz 436552 SHA256 aea04697a28d809054fb59c4c0b94912757037981dedbec1be47d09fe10749b3 SHA512 723f5b78f91ca873c8f79aee714428dfc3cfabbb65ac1eff3364d5ac6ded7fe5fc03d78dfc3b6c329d37e277e431a75b634f3c30485b33704a6d25f56379ad8f WHIRLPOOL 6bdef24de13d207c4b8f1ee9a2a5f4586d8aa4c3e97e3d6d746bfe69c865257b2a18b4598abc5189b3eb2e89e4e2ad0f328dd69f187b52cdffb3f82214eb8466
85 changes: 85 additions & 0 deletions sys-libs/talloc/talloc-2.1.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,85 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads"

inherit waf-utils python-single-r1 multilib multilib-minimal

DESCRIPTION="Samba talloc library"
HOMEPAGE="http://talloc.samba.org/"
SRC_URI="http://samba.org/ftp/${PN}/${P}.tar.gz"

LICENSE="GPL-3 LGPL-3+ LGPL-2 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~sparc-solaris"
IUSE="compat +python"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

RDEPEND="python? ( ${PYTHON_DEPS} )
!!<sys-libs/talloc-2.0.5
abi_x86_32? (
!<=app-emulation/emul-linux-x86-baselibs-20140508-r1
!app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
)"
DEPEND="${RDEPEND}
sys-devel/gettext
dev-libs/libxslt
${PYTHON_DEPS}"

WAF_BINARY="${S}/buildtools/bin/waf"

MULTILIB_WRAPPED_HEADERS=(
# python goes only for native
/usr/include/pytalloc.h
)

src_prepare() {
# what would you expect of waf? i won't even waste time trying.
multilib_copy_sources
}

multilib_src_configure() {
local extra_opts=()

use compat && extra_opts+=( --enable-talloc-compat1 )
if ! multilib_is_native_abi || ! use python; then
extra_opts+=( --disable-python )
fi

waf-utils_src_configure \
"${extra_opts[@]}"
}

multilib_src_compile() {
waf-utils_src_compile
}

multilib_src_install() {
waf-utils_src_install

# waf is stupid, and no, we can't fix the build-system, since it's provided
# as a brilliant binary blob thats decompressed on the fly
if [[ ${CHOST} == *-darwin* ]] ; then
install_name_tool \
-id "${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
"${ED}"/usr/$(get_libdir)/libtalloc.2.0.5.dylib || die
if use python ; then
install_name_tool \
-id "${EPREFIX}"/usr/$(get_libdir)/libpytalloc-util.2.dylib \
"${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
install_name_tool \
-change "${S}/bin/default/libtalloc.dylib" \
"${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
"${ED}"/usr/$(get_libdir)/libpytalloc-util.2.0.5.dylib || die
install_name_tool \
-change "${S}/bin/default/libtalloc.dylib" \
"${EPREFIX}"/usr/$(get_libdir)/libtalloc.2.dylib \
"${ED}"$(python_get_sitedir)/talloc.bundle || die
fi
fi
}

0 comments on commit 9825e96

Please sign in to comment.