Skip to content

Commit

Permalink
www-apps/kibana-bin: bump to 5.6.3.
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Closes: gentoo#5933
  • Loading branch information
hydrapolic authored and monsieurp committed Oct 15, 2017
1 parent 802da22 commit 984ede8
Show file tree
Hide file tree
Showing 2 changed files with 68 additions and 0 deletions.
2 changes: 2 additions & 0 deletions www-apps/kibana-bin/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,5 @@ DIST kibana-5.5.2-linux-x86.tar.gz 50521894 SHA256 f74e16d73da0b31e8c04276b13f75
DIST kibana-5.5.2-linux-x86_64.tar.gz 51073441 SHA256 4b879a36899d886c1264c6c2e0c662d56ebefee703fa4c62bca793124d3ebd5a SHA512 eab223176ea2a92234cf074a245024f1612e66361811a481f2ae9199afd92b4d01e10048adf1cb5ca3a60ef4d671705b70dc39c76e90d5c1ab5d07851d0b0096 WHIRLPOOL 05d12811a929507b01ac1a48c3aa038cab0b944e85d2b95272a4ddacec5325da697033e4f063648f39debfc2a0fffb7e15c6bdc141e5cf7641ce9df66572b2dc
DIST kibana-5.6.2-linux-x86.tar.gz 50262246 SHA256 de69314c6616ca9e467b67c9b3800ca1c1cc843a8709a4cb435ba017a3affcc8 SHA512 0d637a52c50edb1fdd4418802c1dd145806a36ce21fb34182485d046d1352156e6f8e4a26ef0b8c92bc09266fe95618c58ad1cd022bba4acf07c528ae5429a43 WHIRLPOOL bcacc1b2b312949626d0792d39382d7af1110089e569fcbf52330119ee67ae62cfadc7a87fd8bd6006ab2423f2067e406bbbf62f5988ad1950fd09ad5240515c
DIST kibana-5.6.2-linux-x86_64.tar.gz 50813652 SHA256 d4fb6a736c367d8df563f405bdc3c6d6541e1a8fe0b22d29c8070c032ca97cd8 SHA512 e9ef4f8dee16b1274d4b0399c0df938a5c99d450f8b8f8b1e56b3410661696b67a100187aa719c270359bd22b000dc5002c664d33eb178fd657dc80ae8237830 WHIRLPOOL ce9f9eccf63573395bfd91afd922775acee616ef281d94ca279a0e5f0c4e2d85a88945489ad1fb67240d0339a9d8e30a9c2189883dfb973ac25adb656a08441e
DIST kibana-5.6.3-linux-x86.tar.gz 51033619 SHA256 a34e20bae6c0d3165a185919460293d0c060fe8ea94b7488cf1d73c5cff9e0f2 SHA512 79230e8239709cbb59608db20937e62a96662217a4317b6ec83990373fb6396fee9a6852a14cd0a074c80dc1d3d02fe90b10a12857a0c079fad0ca53561479fb WHIRLPOOL 59a05bcdf2fc93759121c5fa7efc72b4dcdb6489cf30cbe6727c4c8873c1cb4c21e67802e79218b741fecc65c827d99a41ddaa3545aeb90144e377ef2d338b34
DIST kibana-5.6.3-linux-x86_64.tar.gz 51583164 SHA256 6f3df48dabf51917252b1d99bea03a66e981812b27097645cc3cbb53281a1c71 SHA512 fe957f0a2def9fb40be32ac77986d5eb7cc3373f828eed8eae074770ef965cf01c36028f2f9790f927e217ee59a283e63273eb768b9d2375aa0cdf15e4963c9a WHIRLPOOL 7ea2e5520060029eb592449b01b8ad78582f5446d8e580f58384dce4e75b6d90b49d90ce5cb3622db1ae8aa599e436870c2b1343218a3ee8fd0c5f0f623180c7
66 changes: 66 additions & 0 deletions www-apps/kibana-bin/kibana-bin-5.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit user

MY_PN="${PN%-bin}"
MY_P=${MY_PN}-${PV}

DESCRIPTION="Analytics and search dashboard for Elasticsearch"
HOMEPAGE="https://www.elastic.co/products/kibana"
SRC_URI="amd64? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86_64.tar.gz )
x86? ( https://artifacts.elastic.co/downloads/${MY_PN}/${MY_P}-linux-x86.tar.gz )"

# source: LICENSE.txt and NOTICE.txt
LICENSE="Apache-2.0 Artistic-2 BSD BSD-2 CC-BY-3.0 CC-BY-4.0 icu ISC MIT MPL-2.0 OFL-1.1 openssl public-domain Unlicense WTFPL-2 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="net-libs/nodejs"

pkg_setup() {
enewgroup ${MY_PN}
enewuser ${MY_PN} -1 -1 /opt/${MY_PN} ${MY_PN}
}

src_unpack() {
if use amd64; then
S="${WORKDIR}/${MY_P}-linux-x86_64"
elif use x86; then
S="${WORKDIR}/${MY_P}-linux-x86"
fi

default

# remove bundled nodejs
rm -rv "${S}"/node || die
}

src_install() {
keepdir /opt/${MY_PN}
keepdir /var/log/${MY_PN}
keepdir /etc/${MY_PN}

insinto /etc/${MY_PN}
doins config/*
rm -rv config || die

insinto /etc/logrotate.d
newins "${FILESDIR}"/${MY_PN}.logrotate ${MY_PN}

newconfd "${FILESDIR}"/${MY_PN}.confd ${MY_PN}
newinitd "${FILESDIR}"/${MY_PN}.initd ${MY_PN}

mv * "${ED%/}"/opt/${MY_PN} || die
}

pkg_postinst() {
elog "This version of Kibana is compatible with Elasticsearch 5.6"
elog
elog "Be sure to point ES_INSTANCE to your Elasticsearch instance"
elog "in /etc/conf.d/${MY_PN}."
elog
elog "Elasticsearch can run local or remote."
}

0 comments on commit 984ede8

Please sign in to comment.