Skip to content

Commit

Permalink
Merge remote-tracking branch 'github/pr/323'
Browse files Browse the repository at this point in the history
  • Loading branch information
akhuettel committed Nov 8, 2015
2 parents 8fe77ec + 7519325 commit 988247b
Show file tree
Hide file tree
Showing 9 changed files with 892 additions and 15 deletions.
167 changes: 167 additions & 0 deletions app-office/libreoffice-l10n/Manifest

Large diffs are not rendered by default.

89 changes: 89 additions & 0 deletions app-office/libreoffice-l10n/libreoffice-l10n-4.4.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit rpm eutils multilib versionator

MY_PV=$(get_version_component_range 1-3)

DESCRIPTION="Translations for the Libreoffice suite"
HOMEPAGE="http://www.libreoffice.org"
BASE_SRC_URI_TESTING="http://download.documentfoundation.org/${PN/-l10n/}/testing/${MY_PV}/rpm"
BASE_SRC_URI_STABLE="http://download.documentfoundation.org/${PN/-l10n/}/stable/${MY_PV}/rpm"

LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
IUSE="offlinehelp"

#
# when changing the language lists, please be careful to preserve the spaces (bug 491728)
#
LANGUAGES_HELP=" am ast bg bn_IN bn bo bs ca_valencia ca cs da de dz el en_GB en en_ZA eo es et eu fi fr gl gu he hi hr hu id is it ja ka km ko mk nb ne nl nn om pl pt_BR pt ru si sk sl sq sv tg tr ug uk vi zh_CN zh_TW "
LANGUAGES="${LANGUAGES_HELP}af ar as be br brx cy dgo fa ga gd kk kmr_Latn kn kok ks lb lo lt lv mai ml mn mni mr my nr nso oc or pa_IN ro rw sa_IN sat sd sid sr_Latn sr ss st sw_TZ ta te th tn ts tt uz ve xh zu "

for lang in ${LANGUAGES_HELP}; do
helppack=""
[[ ${lang} == en ]] && lang2=${lang/en/en_US} || lang2=${lang}
helppack="offlinehelp? ( ${BASE_SRC_URI_STABLE}/x86/LibreOffice_${MY_PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz -> LibreOffice_${PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz ${BASE_SRC_URI_TESTING}/x86/LibreOffice_${PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz )"
SRC_URI+=" linguas_${lang}? ( ${helppack} )"
done
for lang in ${LANGUAGES}; do
langpack=""
[[ ${lang} == en ]] \
|| langpack="${BASE_SRC_URI_STABLE}/x86/LibreOffice_${MY_PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz -> LibreOffice_${PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz ${BASE_SRC_URI_TESTING}/x86/LibreOffice_${PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz"
[[ -z ${langpack} ]] || SRC_URI+=" linguas_${lang}? ( ${langpack} )"
IUSE+=" linguas_${lang}"
done
unset lang helppack langpack lang2

RDEPEND+="app-text/hunspell"

RESTRICT="strip"

S="${WORKDIR}"

src_prepare() {
local lang dir rpmdir

# First remove dictionaries, we want to use system ones.
find "${S}" -name *dict*.rpm -delete || die "Failed to remove dictionaries"

for lang in ${LANGUAGES}; do
# break away if not enabled; paludis support
use_if_iuse linguas_${lang} || continue

dir=${lang/_/-}

# for english we provide just helppack, as translation is always there
if [[ ${lang} != en ]]; then
rpmdir="LibreOffice_${PV}_Linux_x86_rpm_langpack_${dir}/RPMS/"
[[ -d ${rpmdir} ]] || die "Missing directory: ${rpmdir}"
rpm_unpack ./${rpmdir}/*.rpm
fi
if [[ "${LANGUAGES_HELP}" =~ " ${lang} " ]] && use offlinehelp; then
[[ ${lang} == en ]] && dir="en-US"
rpmdir="LibreOffice_${PV}_Linux_x86_rpm_helppack_${dir}/RPMS/"
[[ -d ${rpmdir} ]] || die "Missing directory: ${rpmdir}"
rpm_unpack ./${rpmdir}/*.rpm
fi
done
}

src_configure() { :; }
src_compile() { :; }

src_install() {
local dir="${S}"/opt/${PN/-l10n/}$(get_version_component_range 1-2)/
# Condition required for people that do not install anything eg no linguas
# or just english with no offlinehelp.
if [[ -d "${dir}" ]] ; then
insinto /usr/$(get_libdir)/${PN/-l10n/}/
doins -r "${dir}"/*
fi
# remove extensions that are in the l10n for some weird reason
rm -rf "${ED}"usr/$(get_libdir)/${PN/-l10n/}/share/extensions/ || \
die "Failed to remove extensions"
}
24 changes: 11 additions & 13 deletions app-office/libreoffice-l10n/libreoffice-l10n-5.0.3.2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ BASE_SRC_URI_STABLE="http://download.documentfoundation.org/${PN/-l10n/}/stable/

LICENSE="|| ( LGPL-3 MPL-1.1 )"
SLOT="0"
# KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
IUSE="offlinehelp"

#
Expand Down Expand Up @@ -45,11 +45,11 @@ RESTRICT="strip"

S="${WORKDIR}"

src_unpack() {
default
src_prepare() {
local lang dir rpmdir

local lang dir rpmdir i
local ooextused=()
# First remove dictionaries, we want to use system ones.
find "${S}" -name *dict*.rpm -delete || die "Failed to remove dictionaries"

for lang in ${LANGUAGES}; do
# break away if not enabled; paludis support
Expand All @@ -60,21 +60,18 @@ src_unpack() {
# for english we provide just helppack, as translation is always there
if [[ ${lang} != en ]]; then
rpmdir="LibreOffice_${PV}_Linux_x86_rpm_langpack_${dir}/RPMS/"
[[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
# First remove dictionaries, we want to use system ones.
rm -rf "${S}/${rpmdir}/"*dict*.rpm
rpm_unpack "./${rpmdir}/"*.rpm
[[ -d ${rpmdir} ]] || die "Missing directory: ${rpmdir}"
rpm_unpack ./${rpmdir}/*.rpm
fi
if [[ "${LANGUAGES_HELP}" =~ " ${lang} " ]] && use offlinehelp; then
[[ ${lang} == en ]] && dir="en-US"
rpmdir="LibreOffice_${PV}_Linux_x86_rpm_helppack_${dir}/RPMS/"
[[ -d ${rpmdir} ]] || die "Missing directory: \"${rpmdir}\""
rpm_unpack ./"${rpmdir}/"*.rpm
[[ -d ${rpmdir} ]] || die "Missing directory: ${rpmdir}"
rpm_unpack ./${rpmdir}/*.rpm
fi
done
}

src_prepare() { :; }
src_configure() { :; }
src_compile() { :; }

Expand All @@ -87,5 +84,6 @@ src_install() {
doins -r "${dir}"/*
fi
# remove extensions that are in the l10n for some weird reason
rm -rf "${ED}"/usr/$(get_libdir)/${PN/-l10n/}/share/extensions/
rm -rf "${ED}"usr/$(get_libdir)/${PN/-l10n/}/share/extensions/ || \
die "Failed to remove extensions"
}
2 changes: 2 additions & 0 deletions app-office/libreoffice/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -7,9 +7,11 @@ DIST 798b2ffdc8bcfe7bca2cf92b62caf685-rhino1_5R5.zip 1521926 SHA256 1fb458d6aab0
DIST a7983f859eafb2677d7ff386a023bc40-xsltml_2.1.2.zip 23150 SHA256 75823776fb51a9c526af904f1503a7afaaab900fba83eda64f8a41073724c870 SHA512 2d3835f7ac356805025cafedcad97faa48d0f5da386e6ac7b7451030059df8e2fdb0861ade07a576ebf9fb5b88a973585ab0437944b06aac9289d6898ba8586a WHIRLPOOL 60b98d9af2c83c0cf12a5a60ba30957d335b8b967cac07971e1edbc787b9caecd4b3c5bb480e8b38fe8109c1cf74439ebafae130c976182c2c15399f38f5d28c
DIST d62650a6f908e85643e557a236ea989c-vigra1.6.0.tar.gz 16525605 SHA256 1f188ac03a8aa4663223eca8c82f91a55293d066d67127082e29a7dba1a98c9f SHA512 d08a7fe432e8df47d1d8992a45bb5f33149cb75b90eb74b2f2e457628d21a94b17eae0045096b053d2a866bf7710c775581c3e417b5dfaf66601aa18071b7305 WHIRLPOOL 95dc6ec0fb293c3538c1d51241283edf4e21647dcfd10229233ab7c3f13f7c78e6bb02c4d292a7cd2a2ec95575d775f0395e837bbc88ab4ddbaa5adfd62be2f0
DIST libreoffice-4.4.5.2.tar.xz 164472672 SHA256 3aeb4f08918c6ca6ec12fc47c2be690d2180c2e41cc3136b6ed36185b89cec0d SHA512 15abecb02d8ca478cb7d006834c8670b9e42d3e5d8ec772e9a1d805dbd2ef1145092d1d4e3a6531f21eeb75210c1354e91c4d3abeec97103ad4c3092b7b7273b WHIRLPOOL a06c9e520e6f2b40c90cb703689527faf9ed6dbe0c0c3810ad276933daa21d56465c286d3de0fe6d5330be7968ae77cff1d30151d62fb34cc7fb57535e82edd6
DIST libreoffice-4.4.6.3.tar.xz 164742068 SHA256 3f1bd66fedc34d60448f74e864c1cb79c3e44aeadbd1d0bb9544011d29f422ac SHA512 ffdbe9b46622d30b176f3120e84cd9bd3d0ea35b2759e1886bc3038455bf63a09305cc9c6ceba9e02a6279e12859c78e689ddfe02d60585115ebb0d3787db8bd WHIRLPOOL 9ce888415d9366e0402ac9d6bbb189d41a9bf42aa49bd8b1c90ef9071fbdb5ce4da7bd7029efcf538fd6cf4ec412d246e943b29cffbbd53499d50065103e2566
DIST libreoffice-5.0.2.2.tar.xz 166869100 SHA256 01f0680709432039762fa608bcb1240786d2b6549099a96095aab92dcebbc176 SHA512 7a72ed01b0f9fc131b7241ea4d1bb70bc813752e33d8e823e91a769d77308d2eec2d32a0fac61bdb41fd605a6f91dbaa3d5478a0b150e64fa9f7e47724f46cce WHIRLPOOL 85a592a0f478b1957d22d932adee758d48084c0c7ee00c0549fa8c956fd30f5eead09f6fc802d22d9613bda8da0c708ec99fb6d10fd82e0922c6da96a326a14c
DIST libreoffice-5.0.3.2.tar.xz 167009360 SHA256 77f9c9569c1199d914f38afa01547c1874535c56ad74b19614a0afc3ad66d4bd SHA512 fe49577d26c2241a2e7d6f2e8faa25cacf77dc94dbe76f7dbbf1b208295695298d24842c73444b284e9af2a323b7536cce6727ffab0431ac22d80691a9902e62 WHIRLPOOL 2a907729d9f2b436a0206f558022d9ace69d494106e3c76f9c141d1202438ca7c662eca102595e8143cb4c70cece44447f99b1093e813249433684725f3287d0
DIST libreoffice-branding-gentoo-0.8.tar.xz 151568 SHA256 22722121be062742624e0634beae92289c75e6a99ed507d3bf0a05c5164e3c69 SHA512 785031a699b1d1895ce4b50ffc3ddf645f3a0ef9acdf37facfd18cf75db9484cb8f53a50abb63d6006ead76a80b6ff5aa99661063245ebb84bd64013d713de7f WHIRLPOOL 1f36652a52d501d6548cfa9aa013b3e3a1867aa2b0693d2274cf7816d4aa4e0cde3c7096cc71ed47cf74e5f96da2757bf537f553021f8fd86939accb227bf538
DIST libreoffice-help-4.4.5.2.tar.xz 1876044 SHA256 66044aaff17cdf4d523ceea00197381bb50d4cb86359be83016a838c27761681 SHA512 0d75f41fa3a7593c621fb3cd6e7f94fe24cb5d5251e05f9e67f58e6603853cceb2b4df2cb28228e7bf464d053b5ce068bcae752bdf6ba977fdde20882540c869 WHIRLPOOL 2715278ed374f8850ccd79e94682cc003b69501c7863c84b3dc609b0377277fa523bc8eba41d8045bff344b1cc70f08171f8acc1aebb47914a4ac190ee66bc49
DIST libreoffice-help-4.4.6.3.tar.xz 1875828 SHA256 d3b18c7dc4c68d152c298498f014e82183ade008d9d64a74353df306b286818b SHA512 6871252079738c7c1a44a17dba6aa842411c1c0a7e92a92dcfa3afe0e314edf9ba4d277bacbc558cf26362e94ff1e8370c91a00f81aee697528ba359f5559a3c WHIRLPOOL 2383ce2bf9a52529d7a4d34e8eeb3ea3d74ec547375ab8cb5556e694519976121528019f53ebd287d07ef40dd19a946acdf469ce0b75301c4ed51fc0add6f6f0
DIST libreoffice-help-5.0.2.2.tar.xz 1882964 SHA256 4342a5593ba8a33b1d63549f256a4127a0b51cc1a53faffdc2708f04fef5f094 SHA512 1000423578211dc843dcedb9f864634235ab09d5234f8d8fe2897065207bdf6cd3bca7cdc1b3c012de0c78b585978a25c0df5048779bd0b9a734c9160064e313 WHIRLPOOL 8b92bcd19487c1c286a477ff0dc1b7e6bd9aaf862cfe002fadc25d461add4c4f2f8ee1e45ac0426dc2d27a6322317cacb7f65e9d0a6e6d6dad01075d18476363
DIST libreoffice-help-5.0.3.2.tar.xz 1882292 SHA256 7e5535b8bd9be88170abdef187d3cf16d2cccdb1fdbd4404a22f1cff55bd953e SHA512 73de5507b0e7994a189d5580ad7bfdf842e9a3a10cc0a9bbe39eb11f20e47fa7016f6cf6748ad7c35260587cfc7078eaac6055b439292068a9d9783509bd715d WHIRLPOOL 1e7c79250a407c0eac5f1538290dfe1f04b22799bc04a295cd6dfbf0405dc4478283dea09ede52adf25077729852c11f9f74e98f257c47a8a30b350d83d532ac
Loading

0 comments on commit 988247b

Please sign in to comment.