forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.3.1
- Loading branch information
Showing
2 changed files
with
73 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST gnote-3.20.1.tar.xz 3304760 SHA256 75acffdc2c0cc8cd226dc4471e6624d523bbd86c415ef4e05be70cbbfd4014e7 SHA512 1547442fec255579588404c17faa4ec7a8fc3445b68b55bd115b57daeb1924e77ba97b4a7b8c19979b97072912b4b761a6e7155370605a920cdc684dff5da222 WHIRLPOOL f21ea792c271ed72aa5b2f8fc420ac09abafecc421da8e98084cdbca67c2a4fec8a180883fe476d89a44f55278430d472639abd89f3b3abcd1e1aa6c5009c138 | ||
DIST gnote-3.20.2.tar.xz 3304528 SHA256 fdc76ae31dc8925545806c1702cf74e1c8f387b16519ed995987194f688555eb SHA512 59d28a8e9069abfbb0f9d29be31d31d39406b374bf9fce434cdb626b508faace5a7505d5fd08196fba938059d7100d85c837a71d97a27345ddf439c569aabc91 WHIRLPOOL 7ae787a43cc6e66400b607f68d2153a0c5651389a134b6870603aacfd278f06d06e41cc147c8f556936b5a85c807d606a44fcd09ce490415d135f614945ae392 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
GNOME2_LA_PUNT="yes" | ||
|
||
inherit gnome2 readme.gentoo-r1 | ||
|
||
DESCRIPTION="Desktop note-taking application" | ||
HOMEPAGE="https://wiki.gnome.org/Apps/Gnote" | ||
|
||
LICENSE="GPL-3+ FDL-1.1" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="debug" | ||
|
||
# Automagic glib-2.32 dep | ||
COMMON_DEPEND=" | ||
>=app-crypt/libsecret-0.8 | ||
>=app-text/gtkspell-3.0:3 | ||
>=dev-cpp/glibmm-2.32:2 | ||
>=dev-cpp/gtkmm-3.18:3.0 | ||
>=dev-libs/boost-1.34:= | ||
>=dev-libs/glib-2.32:2[dbus] | ||
>=dev-libs/libxml2-2:2 | ||
dev-libs/libxslt | ||
>=sys-apps/util-linux-2.16:= | ||
>=x11-libs/gtk+-3.16:3 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
gnome-base/gsettings-desktop-schemas | ||
" | ||
DEPEND="${DEPEND} | ||
app-text/docbook-xml-dtd:4.1.2 | ||
dev-util/desktop-file-utils | ||
>=dev-util/intltool-0.35.0 | ||
dev-util/itstool | ||
virtual/pkgconfig | ||
" | ||
|
||
src_prepare() { | ||
# Do not alter CFLAGS | ||
sed 's/-DDEBUG -g/-DDEBUG/' -i configure.ac configure || die | ||
|
||
gnome2_src_prepare | ||
|
||
if has_version net-fs/wdfs; then | ||
DOC_CONTENTS="You have net-fs/wdfs installed. app-misc/gnote will use it to | ||
synchronize notes." | ||
else | ||
DOC_CONTENTS="Gnote can use net-fs/wdfs to synchronize notes. | ||
If you want to use that functionality just emerge net-fs/wdfs. | ||
Gnote will automatically detect that you did and let you use it." | ||
fi | ||
} | ||
|
||
src_configure() { | ||
gnome2_src_configure \ | ||
--disable-static \ | ||
$(use_enable debug) | ||
} | ||
|
||
src_install() { | ||
gnome2_src_install | ||
readme.gentoo_create_doc | ||
} | ||
|
||
pkg_postinst() { | ||
gnome2_pkg_postinst | ||
readme.gentoo_print_elog | ||
} |