Skip to content

Commit

Permalink
dev-util/dialog: Version 1.3.20190211
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.60, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Feb 15, 2019
1 parent 22e3d2e commit 98aa6ec
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/dialog/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST dialog-1.3-20170131.tgz 507783 BLAKE2B a98c436eabc8d06619bd64a8b1d647a0712630f0f89565253636ef2f38333ca6926177aa0c2001305b0c06fc7a1f576cda87da493183402ef9ec3cdc3fa8be23 SHA512 818b4e9d0d5ee55377b78ccceacf59a78e5e6d6fbc09e24a19e62b4988ff8de32f3364132b9ee88c86e126114eda45c82d86397d5f26fae81a6bda91be979786
DIST dialog-1.3-20181022.tgz 531815 BLAKE2B c6a34010eb991683356338009998964fde60bcae4181d8b07e6d5b9f0d0e9a61d3f0b112fad02c151b1774380e18b87f93f43fdfe35e0fba86914c029eaa274c SHA512 5d7891086ab6d2f4a815538513b09754a56368bbb0ec3bd107346fd2ed6ae10fa858173447fa609cce28a91e234ed8067d9439efeb973593fff2df1e811a8925
DIST dialog-1.3-20181107.tgz 531872 BLAKE2B 7724d66bbb953ff118baf5f135810f40fca30bde6a4a340306da322e9adb4b40e105376c316945b7f70ee2be2698f1bee88bd040c22b5662685448145ccff0a8 SHA512 69cb367bc9a1d6dcd69b74f7eae9b4318f0bfd9c0eae48144da119df10f7f81ed4c215a8882d72dfbbd9ff41c5e591c80b168b9552e014454cc80c9aa37dca55
DIST dialog-1.3-20190211.tar.gz 534749 BLAKE2B 3b721cf98b961c60a97975b7720722d4a46a47d7b861fb7c27de2db2fc3fa704d249b40bf28a6845f68cffabf41b66d77d5f1acf49a342e38cb83a24907e9379 SHA512 247639190c97c1baa6aa2cc75bc17593a0e33fcfcfd6dbc4a1903b55709f8f102c965de03f0620c48463f018525eb77f9b62b39db8331b811a227bbf39b254c4
51 changes: 51 additions & 0 deletions dev-util/dialog/dialog-1.3.20190211.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6
inherit eutils multilib versionator

DIA_P="${PN}-$(replace_version_separator 2 '-')"
DESCRIPTION="tool to display dialog boxes from a shell"
HOMEPAGE="https://invisible-island.net/dialog/"
SRC_URI="https://dev.gentoo.org/~jer/${DIA_P}.tar.gz"

LICENSE="GPL-2"
SLOT="0/15"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="examples minimal nls static-libs unicode"

RDEPEND="
>=sys-libs/ncurses-5.2-r5:=[unicode?]
"
DEPEND="
${RDEPEND}
nls? ( sys-devel/gettext )
!minimal? ( sys-devel/libtool )
!<=sys-freebsd/freebsd-contrib-8.9999
"
S=${WORKDIR}/${DIA_P}

src_prepare() {
default
sed -i -e '/LIB_CREATE=/s:${CC}:& ${LDFLAGS}:g' configure || die
sed -i '/$(LIBTOOL_COMPILE)/s:$: $(LIBTOOL_OPTS):' makefile.in || die
}

src_configure() {
econf \
--disable-rpath-hack \
$(use_enable nls) \
$(use_with !minimal libtool) \
--with-libtool-opts=$(usex static-libs '' '-shared') \
--with-ncurses$(usex unicode w '')
}

src_install() {
use minimal && default || emake DESTDIR="${D}" install-full

use examples && dodoc -r samples

dodoc CHANGES README

prune_libtool_files
}

0 comments on commit 98aa6ec

Please sign in to comment.