Skip to content

Commit

Permalink
dev-util/android-tools: add 33.0.3
Browse files Browse the repository at this point in the history
Closes: gentoo#27409
Signed-off-by: Alfred Wingate <[email protected]>
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
parona-source authored and zmedico committed Sep 23, 2022
1 parent f53056d commit 98e825e
Show file tree
Hide file tree
Showing 2 changed files with 85 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/android-tools/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST android-tools-31.0.3-install-e2fsdroid-ext2simg.patch 2164 BLAKE2B 7f0b43ff
DIST android-tools-31.0.3-no-gtest.patch 3152 BLAKE2B da71e3cba87b21ffcb144602a06d7e269faabd173233363b757cd2191c051f8d3281f591117d4551d7acc029d6e2d421f702f9f836dfe0dec6c676aa39a2d9fe SHA512 a28d2264bf40c420a279acf1f4c3b4588d96ce2d6e2d6d322abbde62d773804bef10dc33f13dd52c7de80ace6c58f91ae28f5d4e8e97dfae4d2a8473d8537423
DIST android-tools-31.0.3.tar.xz 25768908 BLAKE2B e8ca8ff93fcd3936f447926769d7b45194dd96ad99cddd570183a1cbae34dbf49a23e0c53d9eb8f5c25dd09717e1f160829752dc7ebc9404c804b48de8de9889 SHA512 d2c16325b190f77a8ffa38de18ae1aea4bf6848926620f25d14873dc4a3fda3fe2b13349fa2eee197b960ca65738a4a1d2c1f28cf8286ab79e73502e7a8e6357
DIST android-tools-31.0.3p2.tar.xz 22458776 BLAKE2B a51f839ac44e6e998092d802eb182566f4dc2a7f47a5687e0c877fa4fa6d419b16054f75066a6afe8e458e44f8bc5750ca88a2517619379d1044202d64b2ec80 SHA512 367a502c11a136ff15a060df44df14ceec46eb5eb386babb4d38783622e363421d2ec9a65a5810fb8f2b308912c2bdb980e6fce24ba532a111e413647efe67d5
DIST android-tools-33.0.3.tar.xz 25300756 BLAKE2B 4254f0ab8657966cf56e2a7c3e9a3d889dfa9f26e61d8b46480bb74c5a8be33494f450827e3b2db4087006b3160892e6a846ef33719870cbbd032647cfc3ce78 SHA512 78c8141f5f13f1c0e5da474e1d79760a612e911519af4e9f21c0e5005f2ce99f3aeacf16f3fcdfe1250fc795a88190fa243592e1066a2156e1fd8d2b9c3d7f71
84 changes: 84 additions & 0 deletions dev-util/android-tools/android-tools-33.0.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,84 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..11} )

inherit cmake python-r1

DESCRIPTION="Android platform tools (adb, fastboot, and mkbootimg)"
HOMEPAGE="https://github.com/nmeum/android-tools/ https://developer.android.com/"

MY_PV="${PV//_/}"
SRC_URI="https://github.com/nmeum/android-tools/releases/download/${MY_PV}/${PN}-${MY_PV}.tar.xz
https://dev.gentoo.org/~zmedico/dist/${PN}-31.0.3-no-gtest.patch
"
S="${WORKDIR}/${PN}-${MY_PV}"

# The entire source code is Apache-2.0, except for fastboot which is BSD-2.
LICENSE="Apache-2.0 BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~x86-linux"
IUSE="python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

# dev-libs/libpcre only required for e2fsdroid
DEPEND="
app-arch/brotli:=
app-arch/lz4:=
app-arch/zstd:=
dev-libs/libpcre2:=
>=dev-libs/protobuf-3.0.0:=
sys-libs/zlib:=
virtual/libusb:1=
"
RDEPEND="${DEPEND}
python? ( ${PYTHON_DEPS} )
"
BDEPEND="
dev-lang/go
"

DOCS=()

src_prepare() {
eapply "${DISTDIR}/${PN}-31.0.3-no-gtest.patch"
cd "${S}/vendor/core" || die
eapply "${S}/patches/core/0011-Remove-the-useless-dependency-on-gtest.patch"
cd "${S}/vendor/libziparchive" || die
eapply "${S}/patches/libziparchive/0004-Remove-the-useless-dependency-on-gtest.patch"
cd "${S}"
rm -r patches || die
cmake_src_prepare
}

src_configure() {
local mycmakeargs=(
# Statically link the bundled boringssl
-DBUILD_SHARED_LIBS=OFF
)
cmake_src_configure
}

src_compile() {
export GOCACHE="${T}/go-build"
export GOFLAGS="-mod=vendor"
cmake_src_compile
}

src_install() {
cmake_src_install
rm "${ED}/usr/bin/mkbootimg" || die
rm "${ED}/usr/bin/unpack_bootimg" || die
rm "${ED}/usr/bin/repack_bootimg" || die
if use python; then
python_foreach_impl python_newexe vendor/mkbootimg/mkbootimg.py mkbootimg
python_foreach_impl python_newexe vendor/mkbootimg/unpack_bootimg.py unpack_bootimg
python_foreach_impl python_newexe vendor/mkbootimg/repack_bootimg.py repack_bootimg
fi
docinto adb
dodoc vendor/adb/*.{txt,TXT}
docinto fastboot
dodoc vendor/core/fastboot/README.md
}

0 comments on commit 98e825e

Please sign in to comment.