Skip to content

Commit

Permalink
games-rpg/grimrock: Bump to 20150707, EAPI 6, no bundling
Browse files Browse the repository at this point in the history
This previously bundled SDL 2, probably because it wasn't packaged
when this was first added. With that unbundled, there are far fewer
dependencies and this makes unbundling everything less likely to
break. SDL is particularly stable in this regard. Because of this and
in the interests of security, I have dropped the bundled-libs
flag. Anyone experiencing issues can obviously file a bug report.

I swapped the wrapper script for a symlink as the latter works fine.

I dropped the message about libtxc_dxtn because this is no longer
necessary with recent versions of Mesa.

Package-Manager: Portage-2.3.24, Repoman-2.3.6
  • Loading branch information
chewi committed Mar 15, 2018
1 parent a8d4a8c commit 98ea9eb
Show file tree
Hide file tree
Showing 4 changed files with 71 additions and 126 deletions.
2 changes: 1 addition & 1 deletion games-rpg/grimrock/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1 @@
DIST LegendOfGrimrock-Linux-2013-05-15.sh 316846010 SHA256 005066be6ce12ba342e499369070113c6b66a9bea03c6ecb1e5fd0758eb0c39d SHA512 e4907ddfba9a6923f81f188d1452a1bf37e4bbaab4fb9b4befabe167b5159d35acd6c1939b98dd66e3a8f96775d12703206432f60a86c7b4d070acc3a9392f9c WHIRLPOOL a7a5c70c6622737f9904962b248578261137b0c098e7175e309d3470b798b7297dc8aeb42e36b00f809c20f5f105fdfeb75edecca33e94f0d06650f564f02487
DIST Grimrock-Linux-2015-07-07.sh 316846242 BLAKE2B 5d8123b3e2dedf4d6b2ae6f43c9ebe5427e63205b7ff53dc0fba26b0b3a8a1f164b79a3a10776c751aa0fbe29c7ef715412bff826476894eec6aa545da4adec3 SHA512 c90203a747564223281fb61ffcc7ac90f772990f33bb8345aff68c65fbc371f0f1a611645e952a75bd9dbca9e760398c0411eb9adade9c58e525a5b1c4e186db
122 changes: 0 additions & 122 deletions games-rpg/grimrock/grimrock-20130515.ebuild

This file was deleted.

70 changes: 70 additions & 0 deletions games-rpg/grimrock/grimrock-20150707.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,70 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit desktop gnome2-utils unpacker

TIMESTAMP="${PV:0:4}-${PV:4:2}-${PV:6:2}"
MY_PN="Grimrock"
DESCRIPTION="Legend of Grimrock: The ultimate dungeon crawling RPG + modding engine"
HOMEPAGE="http://www.grimrock.net/"
SRC_URI="Grimrock-Linux-${TIMESTAMP}.sh"

SLOT="0"
LICENSE="all-rights-reserved"
KEYWORDS="-* ~amd64 ~x86"
RESTRICT="fetch bindist splitdebug"

QA_PREBUILT="/opt/${PN}/${MY_PN}.bin"

RDEPEND="media-libs/freeimage
media-libs/freetype:2
media-libs/openal
media-libs/libsdl2[opengl,sound,video]
media-libs/libvorbis
sys-libs/zlib[minizip]
virtual/opengl
x11-libs/libX11"

DEPEND="app-arch/xz-utils"

S="${WORKDIR}"

pkg_nofetch() {
einfo "Please buy and download ${SRC_URI} from:"
einfo " ${HOMEPAGE}"
einfo "and move it to your distfiles directory."
}

src_unpack() {
myarch=$(usex amd64 x86_64 x86)
unpack_makeself

local i
for i in subarch instarchive_all instarchive_linux_${myarch}; do
ln -snf "${i}" "${i}.tar.xz" || die
unpack ./"${i}.tar.xz"
done
}

src_install() {
local dir=/opt/${PN}

insinto "${dir}"
doins ${PN}.{dat,png}

exeinto "${dir}"
newexe ${MY_PN}.bin{.${myarch},}
dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN}

doicon -s 256 ${PN}.png
newicon -s 64 ${MY_PN}.png ${PN}.png
make_desktop_entry ${PN} "Legend of ${MY_PN}"

dodoc README.linux
}

pkg_preinst() { gnome2_icon_savelist; }
pkg_postinst() { gnome2_icon_cache_update; }
pkg_postrm() { gnome2_icon_cache_update; }
3 changes: 0 additions & 3 deletions games-rpg/grimrock/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,4 @@
<email>[email protected]</email>
<name>Gentoo Games Project</name>
</maintainer>
<use>
<flag name="bundled-libs">Use bundled libraries.</flag>
</use>
</pkgmetadata>

0 comments on commit 98ea9eb

Please sign in to comment.