forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Package-Manager: portage-2.2.28
- Loading branch information
Showing
4 changed files
with
89 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1 @@ | ||
DIST luasystem-0.2.0_p0.tar.gz 8058 SHA256 1c4aea8e5b6205e4ea9739c2fbf185d45b0ab7572397a29d5d3d2e5b5f549054 SHA512 b8c7ba30470cbf100cc3f14df31729778cfb0aabebe4d27ce42c19581a2585f878d86a29a2f73fd1bef4e5861e2a604d3c396a73f131fa99ae14a17cba52c336 WHIRLPOOL 5c6770deddf27a4deb8ada3069caa3edd479c1dbeecb068ea3ea6a219bee968b1a6dde008599572674fdec119d31d40a01d31b4a1e3dbcc3009e5598f6b2aff2 |
33 changes: 33 additions & 0 deletions
33
dev-lua/luasystem/files/luasystem-0.2.0_p0-fix-makefile.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
diff --git a/src/Makefile b/src/Makefile | ||
index 10fc31a..af5e4e4 100644 | ||
--- a/src/Makefile | ||
+++ b/src/Makefile | ||
@@ -144,8 +144,8 @@ O_linux=o | ||
CC_linux=gcc | ||
DEF_linux= | ||
CFLAGS_linux= -I$(LUAINC) $(DEF) -Wall -Wshadow -Wextra \ | ||
- -Wimplicit -O2 -ggdb3 -fpic -fvisibility=hidden | ||
-LDFLAGS_linux=-lrt -O -shared -fpic -o | ||
+ -Wimplicit -fpic -fvisibility=hidden | ||
+LDFLAGS_linux=-lrt -shared -fpic -o | ||
LD_linux=gcc | ||
|
||
#------ | ||
@@ -208,7 +208,7 @@ SOLIB=core.$(SO) | ||
# | ||
CC=$(CC_$(PLAT)) | ||
DEF=$(DEF_$(PLAT)) | ||
-CFLAGS=$(MYCFLAGS) $(CFLAGS_$(PLAT)) | ||
+CFLAGS=$(CFLAGS_$(PLAT)) $(MYCFLAGS) | ||
LDFLAGS=$(MYLDFLAGS) $(LDFLAGS_$(PLAT)) | ||
LD=$(LD_$(PLAT)) | ||
LUAINC= $(LUAINC_$(PLAT)) | ||
@@ -248,7 +248,7 @@ none: | ||
all: $(SOLIB) | ||
|
||
$(SOLIB): $(OBJS) | ||
- $(LD) $(OBJS) $(LDFLAGS)$@ | ||
+ $(LD) $(OBJS) $(LDFLAGS) $@ | ||
|
||
install: all | ||
$(INSTALL_DIR) $(INSTALL_TOP_LDIR) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,45 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
|
||
inherit toolchain-funcs | ||
|
||
# The below is the upstream version number. The -x suffix should be kept | ||
# in sync with the _px suffix in the ebuild version. | ||
MY_PV="0.2.0-0" | ||
|
||
DESCRIPTION="platform independent system calls for lua" | ||
HOMEPAGE="https://github.com/LuaDist2/luasystem" | ||
SRC_URI="https://github.com/LuaDist2/luasystem/archive/${MY_PV}.tar.gz -> | ||
${P}.tar.gz" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
KEYWORDS="~amd64" | ||
IUSE="" | ||
|
||
COMMON_DEPEND=">=dev-lang/lua-5.1:=" | ||
DEPEND="${COMMON_DEPEND} | ||
virtual/pkgconfig" | ||
RDEPEND="${COMMON_DEPEND}" | ||
|
||
S="${WORKDIR}/${PN}-${MY_PV}" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${P}-fix-makefile.patch | ||
) | ||
|
||
src_compile() { | ||
emake CC="$(tc-getCC)" MYCFLAGS="${CFLAGS}" \ | ||
LD="$(tc-getCC)" MYLDFLAGS="${LDFLAGS}" | ||
} | ||
|
||
src_install () { | ||
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)" | ||
doins -r system | ||
exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/system | ||
doexe src/core.so | ||
dodoc README.md | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
<?xml version="1.0" encoding="UTF-8"?> | ||
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd"> | ||
<pkgmetadata> | ||
<maintainer type="person"> | ||
<email>[email protected]</email> | ||
<name>William Hubbs</name> | ||
</maintainer> | ||
<longdescription lang="en"> | ||
</longdescription> | ||
</pkgmetadata> |