Skip to content

Commit

Permalink
media-sound/jack2: Version bump to 1.9.11-rc1
Browse files Browse the repository at this point in the history
  • Loading branch information
simonvanderveldt authored and aballier committed Jun 18, 2017
1 parent e46ec34 commit 9907ef3
Show file tree
Hide file tree
Showing 3 changed files with 91 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-sound/jack2/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST jack2-1.9.10.tar.gz 6415555 SHA256 88f1b6601b7c8950e6a2d5940b423a33ee628ae5583da40bdce3d9317d8c600d SHA512 0bee815356e9e572224e7cc484c402f38797d70257c4bc79a47552ae30a25a4600c61f712a73cbbede52cd8cb8dc144c9334e28c10e23354a11b7223ee0bb0ca WHIRLPOOL a7b4e14fb1e0490955a363fe0680558d89f80c3cdf18a840991b636518ecf55d872d91d9024770874b5d28494e2cbadc0f21ce4b73ee7873f62842fb0339b0c5
DIST jack2-1.9.11-RC1.tar.gz 6481650 SHA256 730eee0de2136e62b358f4b65d9e30109d706d2627eb2998e43763b47b17474f SHA512 4fd7d82ab6536b8c6061023858ae5b978903608b149498818971481da75c6e9e0e7e7aef5e1343730c259f4378aebfbf25916b9736e0ad8aa19584a44f894436 WHIRLPOOL 6401f16b5ef5331602c6b3c14c709adf17f765700959d87494738960c8e1407cc894789ef8b11452ca9621a9e18e93407d81ede0846118efbb81560bbe9435e6
89 changes: 89 additions & 0 deletions media-sound/jack2/jack2-1.9.11_rc1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,89 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads(+)"
inherit eutils python-single-r1 waf-utils multilib-minimal

DESCRIPTION="Jackdmp jack implemention for multi-processor machine"
HOMEPAGE="http://jackaudio.org/"

if [[ "${PV}" = "2.9999" ]]; then
inherit git-r3
EGIT_REPO_URI="git://github.com/jackaudio/jack2.git"
KEYWORDS=""
else
MY_PV="${PV/_rc/-RC}"
MY_P="${PN}-${MY_PV}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/jackaudio/jack2/archive/v${MY_PV}.tar.gz -> ${MY_P}.tar.gz"
KEYWORDS="~amd64 ~ppc ~x86"
fi

LICENSE="GPL-2"
SLOT="2"
IUSE="alsa celt dbus doc opus pam classic sndfile libsamplerate readline"

REQUIRED_USE="${PYTHON_REQUIRED_USE}"

CDEPEND="media-libs/libsamplerate
media-libs/libsndfile
sys-libs/readline:0=
${PYTHON_DEPS}
alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
celt? ( media-libs/celt:0[${MULTILIB_USEDEP}] )
dbus? (
dev-libs/expat[${MULTILIB_USEDEP}]
sys-apps/dbus[${MULTILIB_USEDEP}]
)
opus? ( media-libs/opus[custom-modes,${MULTILIB_USEDEP}] )"
DEPEND="!media-sound/jack-audio-connection-kit:0
${CDEPEND}
virtual/pkgconfig
doc? ( app-doc/doxygen )"
RDEPEND="${CDEPEND}
dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
pam? ( sys-auth/realtime-base )"

DOCS=( ChangeLog README README_NETJACK2 TODO )

src_prepare() {
default
multilib_copy_sources
}

multilib_src_configure() {
local mywafconfargs=(
--htmldir=/usr/share/doc/${PF}/html
$(usex dbus --dbus "")
$(usex classic --classic "")
--alsa=$(usex alsa yes no)
--celt=$(usex celt yes no)
--doxygen=$(multilib_native_usex doc yes no)
--firewire=no
--freebob=no
--iio=no
--opus=$(usex opus yes no)
--portaudio=no
--readline=$(multilib_native_usex readline yes no)
--samplerate=$(multilib_native_usex libsamplerate yes no)
--sndfile=$(multilib_native_usex sndfile yes no)
--winmme=no
)

waf-utils_src_configure ${mywafconfargs[@]}
}

multilib_src_compile() {
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_compile
}

multilib_src_install() {
WAF_BINARY="${BUILD_DIR}"/waf waf-utils_src_install
}

multilib_src_install_all() {
python_fix_shebang "${ED}"
}
1 change: 1 addition & 0 deletions media-sound/jack2/metadata.xml
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,7 @@
<flag name="pam">Add basic realtime configuration via <pkg>sys-auth/realtime-base</pkg></flag>
<flag name="celt">Support CELT low delay audio codec (<pkg>media-libs/celt</pkg>)</flag>
<flag name="opus">Support <pkg>media-libs/opus</pkg></flag>
<flag name="classic">Enable building of jackd"</flag>
</use>
<upstream>
<remote-id type="github">jackaudio/jack2</remote-id>
Expand Down

0 comments on commit 9907ef3

Please sign in to comment.