Skip to content

Commit

Permalink
app-cdr/gcdemu: EAPI 8, py3.12
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Mar 3, 2024
1 parent 282075f commit 9918e16
Showing 1 changed file with 60 additions and 0 deletions.
60 changes: 60 additions & 0 deletions app-cdr/gcdemu/gcdemu-3.2.6-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} )

inherit cmake gnome2-utils python-single-r1 xdg-utils

DESCRIPTION="Gtk+ GUI for controlling cdemu-daemon"
HOMEPAGE="https://cdemu.sourceforge.io"
SRC_URI="https://download.sourceforge.net/cdemu/gcdemu/${P}.tar.xz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
REQUIRED_USE="${PYTHON_REQUIRED_USE}"

# librsvg for pixbuf-loader
RDEPEND="
${PYTHON_DEPS}
app-cdr/cdemu-daemon:0/7
$(python_gen_cond_dep '
dev-python/pygobject:3[${PYTHON_USEDEP}]
')
gnome-base/librsvg:2
x11-libs/gdk-pixbuf[introspection]
x11-libs/gtk+:3[introspection]
x11-libs/libnotify[introspection]
"
BDEPEND="
${PYTHON_DEPS}
dev-util/desktop-file-utils
>=dev-util/intltool-0.21
sys-devel/gettext
virtual/pkgconfig
"

DOCS=( AUTHORS README )

src_prepare() {
cmake_src_prepare
python_fix_shebang src/gcdemu
}

src_configure() {
local mycmakeargs=( -DPOST_INSTALL_HOOKS=OFF )
cmake_src_configure
}

pkg_postinst() {
xdg_desktop_database_update
gnome2_schemas_update
}

pkg_postrm() {
xdg_desktop_database_update
gnome2_schemas_update
}

0 comments on commit 9918e16

Please sign in to comment.