Skip to content

Commit

Permalink
dev-java/gradle-bin: Version bump to 3.4.1 as requested by Michael "x…
Browse files Browse the repository at this point in the history
…mw" Weber in bug #612176

Package-Manager: Portage-2.3.5, Repoman-2.3.2
  • Loading branch information
tonyvroon committed May 3, 2017
1 parent 28cb241 commit 991f805
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-java/gradle-bin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gradle-3.3-all.zip 91388147 SHA256 71a787faed83c4ef21e8464cc8452b941b5fcd575043aa29d39d15d879be89f7 SHA512 4b852eaf4030c780516fe9214c289e49fc93fc62672da70b7fd6bbbcd128e6912dd196195ce32570984503ea53b48593a41fbf4ec69b0f18b5e32c2fe9e556b3 WHIRLPOOL d2058d046137b507aecae0ac8ebdc719dc1e1c253162be1975ff9daaca04178398b7621c142ed467a8608bf99d952c1046306aeb3b96626bf70899d7213ba91b
DIST gradle-3.4.1-all.zip 91604607 SHA256 ed7e9c8bb41bd10d4c9339c95b2f8b122f5bf13188bd90504a26e0f00b123b0d SHA512 bdaabf747e60ae1cf2c9fedb0730a2e3deb914609db05ffc7e4cbd5402bc44e84d2c98154f14fdd7f944c2f49eb5dead0f44c119ac5a16bd7491c3369d784f5c WHIRLPOOL b2796d07b6d7f290bde18f46b36348fa6079d42647775e1d6c448c5ebfbb16fc38954da7083f1ce15d2beb7677308e783e4610d4c841e5dbfb49bff620126b24
51 changes: 51 additions & 0 deletions dev-java/gradle-bin/gradle-bin-3.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="6"

inherit java-pkg-2

MY_PN=${PN%%-bin}
MY_P="${MY_PN}-${PV/_rc/-rc-}"

DESCRIPTION="A project automation and build tool with a Groovy based DSL"
SRC_URI="http://services.gradle.org/distributions/${MY_P}-all.zip"
HOMEPAGE="http://www.gradle.org/"
LICENSE="Apache-2.0"
SLOT="${PV}"
KEYWORDS="~x86 ~amd64"

DEPEND="app-arch/zip"
RDEPEND=">=virtual/jdk-1.6"

IUSE="source doc examples"

S="${WORKDIR}/${MY_P}"

src_install() {
local gradle_dir="${EPREFIX}/usr/share/${PN}-${SLOT}"

dodoc docs/release-notes.html getting-started.html

insinto "${gradle_dir}"

# source
if use source ; then
java-pkg_dosrc src/*
fi

# docs
if use doc ; then
java-pkg_dojavadoc docs/javadoc
fi

# examples
if use examples ; then
java-pkg_doexamples samples
fi

insinto "${gradle_dir}"
doins -r bin/ lib/
fperms 755 "${gradle_dir}/bin/gradle"
dosym "${gradle_dir}/bin/gradle" "/usr/bin/${MY_PN}-${SLOT}"
}

0 comments on commit 991f805

Please sign in to comment.