Skip to content

Commit

Permalink
dev-libs/libevdev: Version bump to 1.12.1
Browse files Browse the repository at this point in the history
Signed-off-by: Matt Turner <[email protected]>
  • Loading branch information
mattst88 committed Mar 26, 2022
1 parent ef94e31 commit 9922c67
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/libevdev/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST libevdev-1.12.0.tar.xz 443716 BLAKE2B 1df548cc9bc2472c88308eb2794df7d5636d498631b8873a1957f5cc959097235e64f46f61285a3cbe1abbfe1d968946ae181dfcd8150fecfddf212ed7f4e07e SHA512 6c1c1362d5112cdf3816d1f735c27e625f5463ebf10a83d675cd9364c3fb291ebcb91c051da442f1a36ed28ba7dd99af74546707f61274f7d5715c544a0ed04c
DIST libevdev-1.12.1.tar.xz 446476 BLAKE2B 3b73c50b5e0bdf6dac001c7e34338ece2ba796af711d8f6f9c2928f93a8f41ee484e067c3cb02878de49d631de87229d4b1a377123e385af5997e11f7c556510 SHA512 eefce287a665e4f89eb2e0437dfefd45ecf8925c7dac35a1bdd46158541f77f2032c6146900a30a01321751d55a9b537bd1d61777cca9cfa02c39a6e31c97be4
50 changes: 50 additions & 0 deletions dev-libs/libevdev/libevdev-1.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{8..10} )

inherit meson-multilib python-any-r1

DESCRIPTION="Handler library for evdev events"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/libevdev/ https://gitlab.freedesktop.org/libevdev/libevdev"

if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://gitlab.freedesktop.org/libevdev/libevdev.git"
inherit git-r3
else
SRC_URI="https://www.freedesktop.org/software/libevdev/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi

LICENSE="MIT"
SLOT="0"
IUSE="doc test"

DEPEND="test? ( dev-libs/check[${MULTILIB_USEDEP}] )"
BDEPEND="
${PYTHON_DEPS}
doc? ( app-doc/doxygen )
virtual/pkgconfig
"
RESTRICT="!test? ( test )"

multilib_src_configure() {
local emesonargs=(
$(meson_feature doc documentation)
$(meson_feature test tests)
)
meson_src_configure
}

multilib_src_test() {
meson_src_test -t 100
}

multilib_src_install_all() {
if use doc; then
local HTML_DOCS=( doc/html/. )
einstalldocs
fi
}

0 comments on commit 9922c67

Please sign in to comment.