Skip to content

Commit

Permalink
net-dns/bind-tools: 9.12.1 version bump
Browse files Browse the repository at this point in the history
  • Loading branch information
candrews authored and idl0r committed Apr 19, 2018
1 parent 8e2f4a5 commit 99515b1
Show file tree
Hide file tree
Showing 2 changed files with 144 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-dns/bind-tools/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST bind-9.11.2_p1.tar.gz 9783329 BLAKE2B 5a3bbd87112064231bd5e6b09ebb4014f9d5cf65cb601c03555ff540a22d87aec3990cd8e37ce5ff09e9a149bdf122d20ecb01f87731e6c79d80379a6926014f SHA512 168f27f580e3be2f7ada27afa2f72e715e750eec76831cf01bd32fabc1fa65dc29dab0eb7ed1682b076d3be99269897ddbc2c10551631a3911d9e5ae1aa40597
DIST bind-9.12.1.tar.gz 9302783 BLAKE2B 731ce67acb22f72e54de1122c5d5c3c1f0663c400bdff9545578a45e5fe3094c6d754351e57dd5c52cdfe1528305dfde25eba7382a723a60b8bfdfeebb9536cd SHA512 701e34a0a3313568c8e5cf76668fefc2a1fceb2ade0de201b8f678401569f1c622c3d1657a71772fa3298efc8b3cdefe974d98432c0087e8b45af3d50a4262fb
143 changes: 143 additions & 0 deletions net-dns/bind-tools/bind-tools-9.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,143 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI="5"

inherit eutils autotools flag-o-matic toolchain-funcs

MY_PN=${PN//-tools}
MY_PV=${PV/_p/-P}
MY_PV=${MY_PV/_rc/rc}
MY_P="${MY_PN}-${MY_PV}"

DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
HOMEPAGE="http://www.isc.org/software/bind"
SRC_URI="https://www.isc.org/downloads/file/${MY_P}/?version=tar-gz -> ${MY_PN}-${PV}.tar.gz"

LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc gost gssapi idn ipv6 libedit libressl readline seccomp ssl urandom xml"
# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687

REQUIRED_USE="gost? ( !libressl ssl )"

CDEPEND="
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
gost? ( >=dev-libs/openssl-1.0.0:0=[-bindist] )
xml? ( dev-libs/libxml2 )
idn? ( <net-dns/idnkit-2:= )
gssapi? ( virtual/krb5 )
libedit? ( dev-libs/libedit )
!libedit? (
readline? ( sys-libs/readline:0= )
)
seccomp? ( sys-libs/libseccomp )"
DEPEND="${CDEPEND}
virtual/pkgconfig"
RDEPEND="${CDEPEND}
!<net-dns/bind-9.10.2"

S="${WORKDIR}/${MY_P}"

# bug 479092, requires networking
RESTRICT="test"

src_prepare() {
# Disable tests for now, bug 406399
sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die

# bug #220361
rm aclocal.m4
rm -rf libtool.m4/

mv configure.in configure.ac || die # configure.in is deprecated
eautoreconf
}

src_configure() {
local myconf=

if use urandom; then
myconf="${myconf} --with-randomdev=/dev/urandom"
else
myconf="${myconf} --with-randomdev=/dev/random"
fi

if use libedit ; then
myconf+=' --with-readline=-ledit'
elif use readline ; then
myconf+=' --with-readline=-lreadline'
else
myconf+=' --without-readline'
fi

# bug 344029
append-cflags "-DDIG_SIGCHASE"

# localstatedir for nsupdate -l, bug 395785
tc-export BUILD_CC
econf \
--localstatedir=/var \
--without-python \
--without-libjson \
--without-zlib \
--without-lmdb \
--disable-openssl-version-check \
$(use_enable ipv6) \
$(use_with idn) \
$(usex idn --with-idnlib=-lidnkit '') \
$(use_enable seccomp) \
$(use_with ssl openssl) \
$(use_with xml libxml2) \
$(use_with readline) \
$(use_with gssapi) \
$(use_with readline) \
$(use_with gost) \
${myconf}

# bug #151839
echo '#undef SO_BSDCOMPAT' >> config.h
}

src_compile() {
local AR=$(tc-getAR)

emake AR="${AR}" -C lib/
emake AR="${AR}" -C bin/delv/
emake AR="${AR}" -C bin/dig/
emake AR="${AR}" -C bin/nsupdate/
emake AR="${AR}" -C bin/dnssec/
}

src_install() {
dodoc README CHANGES

cd "${S}"/bin/delv
dobin delv
doman delv.1

cd "${S}"/bin/dig
dobin dig host nslookup
doman {dig,host,nslookup}.1

cd "${S}"/bin/nsupdate
dobin nsupdate
doman nsupdate.1
if use doc; then
dohtml nsupdate.html
fi

cd "${S}"/bin/dnssec
for tool in dsfromkey importkey keyfromlabel keygen \
revoke settime signzone verify; do
dobin dnssec-"${tool}"
doman dnssec-"${tool}".8
if use doc; then
dohtml dnssec-"${tool}".html
fi
done
}

0 comments on commit 99515b1

Please sign in to comment.