forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/crypto++: add pkgconfig file for clementine
Read this bug report: clementine-player/Clementine#5279 Package-Manager: portage-2.2.28
- Loading branch information
Showing
2 changed files
with
87 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,75 @@ | ||
# Copyright 1999-2015 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=5 | ||
|
||
inherit eutils flag-o-matic multilib toolchain-funcs autotools | ||
|
||
DESCRIPTION="C++ class library of cryptographic schemes" | ||
HOMEPAGE="http://cryptopp.com" | ||
SRC_URI="mirror://sourceforge/cryptopp/cryptopp${PV//.}.zip" | ||
|
||
LICENSE="Boost-1.0" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x64-macos" | ||
IUSE="static-libs" | ||
|
||
DEPEND="app-arch/unzip | ||
sys-devel/libtool" | ||
|
||
S="${WORKDIR}" | ||
|
||
src_prepare() { | ||
epatch "${FILESDIR}"/${P}-r1-make.patch | ||
epatch "${FILESDIR}"/${P}-cve-2015-2141.patch | ||
|
||
# Generate our own libtool script for building. | ||
cat <<-EOF > configure.ac | ||
AC_INIT(lt, 0) | ||
AM_INIT_AUTOMAKE | ||
AC_PROG_CXX | ||
LT_INIT | ||
AC_CONFIG_FILES(Makefile) | ||
AC_OUTPUT | ||
EOF | ||
touch NEWS README AUTHORS ChangeLog Makefile.am | ||
eautoreconf | ||
} | ||
|
||
src_configure() { | ||
econf $(use_enable static-libs static) | ||
} | ||
|
||
src_compile() { | ||
# higher optimizations cause problems | ||
replace-flags -O? -O1 | ||
filter-flags -fomit-frame-pointer | ||
# ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS | ||
[[ ${CHOST} == *-darwin* ]] && append-flags -DCRYPTOPP_DISABLE_X86ASM | ||
|
||
emake -f GNUmakefile CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" LIBTOOL="./libtool" | ||
} | ||
|
||
src_test() { | ||
# ensure that all test vectors have Unix line endings | ||
local file | ||
for file in TestVectors/* ; do | ||
edos2unix ${file} | ||
done | ||
|
||
if ! emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" test ; then | ||
eerror "Crypto++ self-tests failed." | ||
eerror "Try to remove some optimization flags and reemerge Crypto++." | ||
die "emake test failed" | ||
fi | ||
} | ||
|
||
src_install() { | ||
emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="${EPREFIX}/usr" LIBTOOL="./libtool" install | ||
use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.la | ||
cp "${FILESDIR}/cryptopp.pc" "${WORKDIR}" || die "Could not find pkg-config file" | ||
sed -i -e "s:^prefix= :prefix= ${EPREFIX}:" -e "s:/,lib,:/$(get_libdir):g" "${WORKDIR}/cryptopp.pc" | ||
insinto "/usr/$(get_libdir)/pkgconfig" | ||
doins "${WORKDIR}/cryptopp.pc" | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
prefix= /usr | ||
exec_prefix=${prefix} | ||
libdir=${exec_prefix}/,lib, | ||
includedir=${prefix}/include | ||
|
||
Name: libcrypto++ | ||
Description: General purpose cryptographic shared library | ||
URL: http://www.cryptopp.com | ||
Version: %version | ||
Requires: | ||
Libs: -lcryptopp | ||
Cflags: |