Skip to content

Commit

Permalink
dev-python/boto3: Bump to 1.28.48
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Sep 15, 2023
1 parent 69c65e3 commit 9965bce
Show file tree
Hide file tree
Showing 2 changed files with 69 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/boto3/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -10,3 +10,4 @@ DIST boto3-1.28.44.gh.tar.gz 698689 BLAKE2B 9c23bd7aa680f59ad686ad5ec46dd751d22b
DIST boto3-1.28.45.gh.tar.gz 699111 BLAKE2B 6873e83e58d4a778b5296c7def5ed5060f5d1d18c1b123e1662be8688a683aac8fe8f10821a59ac0cfb6192e925c15fe8aafc46b6bd1ddc261142024427d9b7a SHA512 8d8f6b9735995ee3ff5f47ddd79d19ec490da116454f7adbf65a22dd592b82727e7528236d4bca577ebe7857a2f9e14ac34357988fb958696b81e54162d8b081
DIST boto3-1.28.46.gh.tar.gz 699277 BLAKE2B 7bc3a739cbb40b56c7b993132571add6d77f6a1941b00a1ae35cfa62a836a7b21dfe572d6ccccaf674b20abfe4895d53d3247c4fa52410fed276ace282a05fd1 SHA512 8a6a1b8325da12e75563cd8fc7973f79d1c2a2e418c8a5401064525381f06800c8a4e282253af3330e301a56fa74290743ea5f0a516bb4f017d8f23c9ed7e43c
DIST boto3-1.28.47.gh.tar.gz 699978 BLAKE2B 056a6c4ac0d94dd147cf1a0e438f9947b2a0bf9f608b5317fe71f58192003cd6de819acc090067cc86124be6ead967bf8cc15ac9061008a15e57cb4259145bb8 SHA512 e0ad5c30677a6c04206a1845ac1cb19a91789885de7ca2cfbac70743e54f8d3254471672c560dc0b97f3d46b6366455521cb78d1c300428ff01f2fdfa1da7ff6
DIST boto3-1.28.48.gh.tar.gz 700213 BLAKE2B 3ddb02067fee032d3d5e493849936b854130def109f46806fe826845da1daa681920448d96658910ec3064d576de1fe6055d514345cbe88d548278c16c2a28a9 SHA512 b561b0631af566a82495d97ba9c4dc58183361868042b70c353004c58c3cfc38c3496eb5a4d387e5272b76f479a7f101676fc3a9b6306d203e5122bde0091e98
68 changes: 68 additions & 0 deletions dev-python/boto3/boto3-1.28.48.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,68 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )

inherit distutils-r1 multiprocessing

DESCRIPTION="The AWS SDK for Python"
HOMEPAGE="
https://github.com/boto/boto3/
https://pypi.org/project/boto3/
"
LICENSE="Apache-2.0"
SLOT="0"

if [[ "${PV}" == "9999" ]]; then
EGIT_REPO_URI="https://github.com/boto/boto3"
inherit git-r3
BOTOCORE_PV=${PV}
else
SRC_URI="
https://github.com/boto/boto3/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"

# botocore is x.(y+3).z
BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
fi

RDEPEND="
>=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
>=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
>=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pytest-xdist[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

python_prepare_all() {
# don't lock versions to narrow ranges
sed -e '/botocore/ d' \
-e '/jmespath/ d' \
-e '/s3transfer/ d' \
-i setup.py || die

# do not rely on bundled deps in botocore (sic!)
find -name '*.py' -exec sed -i \
-e 's:from botocore[.]vendored import:import:' \
-e 's:from botocore[.]vendored[.]:from :' \
{} + || die

distutils-r1_python_prepare_all
}

python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest tests/{functional,unit} \
-p xdist -n "$(makeopts_jobs)" --dist=worksteal
}

0 comments on commit 9965bce

Please sign in to comment.