Skip to content

Commit

Permalink
dev-python/aws-sam-translator: Bump to 1.33.0
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Dec 17, 2020
1 parent df6982a commit 997a2f2
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/aws-sam-translator/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST aws-sam-translator-1.29.0.tar.gz 805869 BLAKE2B 89054fa7e2488b53daf73a78ae1
DIST aws-sam-translator-1.30.1.tar.gz 810865 BLAKE2B 2039e0724d05f7f9d8372b149f04427e0bd1a8a9b503e6dc49ee76cb4e7678d8f759317c43922d190a2bb55a446feffcbf448cdbc9343538b5c77d81b5545e5f SHA512 8fcdf0843f52c8424a78540cf2a9c3922070bcd34a2e0001a17b89b19b471dfbfc4fcd48211b80292d2f7b76eb2881152c68c4d4b56499ab38942c025226d49e
DIST aws-sam-translator-1.31.0.tar.gz 813078 BLAKE2B ae87944bcfe7481db62c0556e1f20defbe5890bebd9b6bc8fe4f597b1ff463ec6382384832451becf5a49361149102a31316ca83e5933d12e0e7e18c9861b9c9 SHA512 fd2b775d2127cce9d78cd3c7ac4dd19f88a94be474f94e4db2486dc96bc88d9a3f621a80bd6dd0b9d70a42df32f3a9164c234a44ce69f84913aa6f4c59ae3682
DIST aws-sam-translator-1.32.0.tar.gz 817649 BLAKE2B 34d606bb294700dac1d3385d173d737d3259f460d0ead302521eb4e2660d3781c49ce5db71e1721245068efdac03eefcfe8963d4915d1e1c60fd783880a95bc9 SHA512 e4adce238434983c56b69960fd673db88edf5b3e4f9356ca4dae508f5a7a8e6bbd3c84050ee606e1fbd578d8f58c5d8196890187e058b7ae2bc8249dbb8ac0d4
DIST aws-sam-translator-1.33.0.tar.gz 817801 BLAKE2B 6e50f299b077f6d0240ee4db80450f766589c5349c323cd846c9ef42dc08bfcb7f8f80099c7d1ecf940d3ba1c2e4628842bf4b1f12e8fcc6c83100f5a375125d SHA512 72fadce4851d782e37e786132d98bcc364c92a1fa48addf715f0d2cf28e286e8cb8835de05fccc67c153d45ed8ba9fd3b7445333f8d96cd70b6c854b8b34c5d6
46 changes: 46 additions & 0 deletions dev-python/aws-sam-translator/aws-sam-translator-1.33.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1

DESCRIPTION="A library that transform SAM templates into AWS CloudFormation templates"
HOMEPAGE="https://github.com/aws/serverless-application-model
https://pypi.org/project/aws-sam-translator/"
SRC_URI="https://github.com/aws/serverless-application-model/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/serverless-application-model-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"

RDEPEND="
>=dev-python/boto3-1.5[${PYTHON_USEDEP}]
>=dev-python/jsonschema-2.6[${PYTHON_USEDEP}]
>=dev-python/six-1.11[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/mock[${PYTHON_USEDEP}]
dev-python/parameterized[${PYTHON_USEDEP}]
)
"

distutils_enable_tests pytest

python_prepare_all() {
# remove pytest-cov dependency
sed -r -e 's:--cov(-[[:graph:]]+|)[[:space:]]+[[:graph:]]+::g' \
-i pytest.ini || die

# don't install tests
sed -e 's:"tests",:"tests", "tests.*",:' -i setup.py || die

# deps are installed by ebuild, don't try to reinstall them via pip
truncate --size=0 requirements/*.txt || die

distutils-r1_python_prepare_all
}

0 comments on commit 997a2f2

Please sign in to comment.