Skip to content

Commit

Permalink
app-arch/makeself: Bump to 2.4.5
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.3
Signed-off-by: Matt Smith <[email protected]>
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
00-matt authored and ionenwks committed Jul 12, 2021
1 parent 77b7edf commit 998750b
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-arch/makeself/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST makeself-2.4.3.tar.gz 32613 BLAKE2B 2295b6d47a8105f2b495260abb0c9ae85875c821d0291a19b5af894c1cef669f338c4e10de8128fe38008e7e08079d1f29949884f202cab680c7fd62e2f00dd9 SHA512 d404c7920c7f69ae29c7168bcf76806b6e2aae2e8916bb7feed998d031ce8b2cd205b83ad960a90b01189c97f9242eb3ef574194ba3ee51c605fe99dafbd6c13
DIST makeself-2.4.4.tar.gz 38889 BLAKE2B eac74fa28ac39cbc6b18d11671bfa32d6c0b04b55b3603c6c928483dd64af38d416936ef242f55aa4840affd4bf7fb91c2987f87afab093816331e50f16379ab SHA512 3d4d03458f7f11a8df46340d1b489ca60d413d5ed857cc67bb8ef15335ce2848e4675e080791c26fdf29423f813d468b4b797438fe0876dad54e85c6346b9b8b
DIST makeself-2.4.5.tar.gz 39012 BLAKE2B f79cf1c087e89c4fd09f328fb795a3f8a78ee38060dbbd1590e3dcdf22a346b0c12bf6837d1636efadb2a66f6a762308de7ee9dd2fc62a7c88d417d257c5f0f6 SHA512 1dae74586f6bd5afb526801b7ffa7fc7962ff74b0f190cdd51da93c21421864b72f5fe18090cb2ff6ad27f0907fbf3aeb5545f3f70e33dbc9e505a78505f5f90
DIST release-2.2.0.tar.gz 21640 BLAKE2B 32b06157829864918d225a136043a5c9b7c6c543351e981c0e3cdce84cbbe4c52f00870bb04d29bfd79e715c1c708b51cc9958d495a9633afb9a8d342601c20d SHA512 11cd536baed2d56405103f18a8318a202092755a74baf10730aa58dc57032e327697b1c7f76bf9bf438927093ba9ac467ffa0c4564c7f6b1d3b2b3936f34fa73
40 changes: 40 additions & 0 deletions app-arch/makeself/makeself-2.4.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

inherit optfeature

DESCRIPTION="Shell script that generates a self-extractible tar.gz"
HOMEPAGE="https://makeself.io/"
SRC_URI="https://github.com/megastep/makeself/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux ~x86-linux"

# NB: The test framework requires bashunit (which isn't a big deal), but the
# tests themselves are not of great quality. You should avoid running them
# yourself as they like to run commands like gpg against your own ~/ settings.
RESTRICT="test"

S="${WORKDIR}/${PN}-release-${PV}"

src_compile() { :; }

src_install() {
dobin makeself-header.sh makeself.sh
dosym makeself.sh /usr/bin/makeself
doman makeself.1
dodoc README.md makeself.lsm
}

pkg_postinst() {
optfeature "lz4 support" app-arch/lz4
optfeature "lzop support" app-arch/lzop
optfeature "pbzip2 support" app-arch/pbzip2
optfeature "pigz support" app-arch/pigz
optfeature "zstd support" app-arch/zstd

# Also bzip2 and xz are supported but they are in @system.
}

0 comments on commit 998750b

Please sign in to comment.