forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Signed-off-by: Sam James <[email protected]>
- Loading branch information
1 parent
59812bc
commit 9997388
Showing
2 changed files
with
122 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,120 @@ | ||
# Copyright 2003-2024 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/elfutils.gpg | ||
inherit flag-o-matic multilib-minimal verify-sig | ||
|
||
DESCRIPTION="Libraries/utilities to handle ELF objects (drop in replacement for libelf)" | ||
HOMEPAGE="https://sourceware.org/elfutils/" | ||
SRC_URI="https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2" | ||
SRC_URI+=" verify-sig? ( https://sourceware.org/elfutils/ftp/${PV}/${P}.tar.bz2.sig )" | ||
|
||
LICENSE="|| ( GPL-2+ LGPL-3+ ) utils? ( GPL-3+ )" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux" | ||
IUSE="bzip2 debuginfod lzma nls static-libs test +utils zstd" | ||
RESTRICT="!test? ( test )" | ||
|
||
RDEPEND=" | ||
!dev-libs/libelf | ||
>=sys-libs/zlib-1.2.8-r1[static-libs?,${MULTILIB_USEDEP}] | ||
bzip2? ( >=app-arch/bzip2-1.0.6-r4[static-libs?,${MULTILIB_USEDEP}] ) | ||
debuginfod? ( | ||
app-arch/libarchive:= | ||
dev-db/sqlite:3= | ||
net-libs/libmicrohttpd:= | ||
net-misc/curl[static-libs?,${MULTILIB_USEDEP}] | ||
) | ||
lzma? ( >=app-arch/xz-utils-5.0.5-r1[static-libs?,${MULTILIB_USEDEP}] ) | ||
zstd? ( app-arch/zstd:=[static-libs?,${MULTILIB_USEDEP}] ) | ||
elibc_musl? ( | ||
dev-libs/libbsd | ||
sys-libs/argp-standalone | ||
sys-libs/fts-standalone | ||
sys-libs/obstack-standalone | ||
) | ||
" | ||
DEPEND=" | ||
${RDEPEND} | ||
" | ||
BDEPEND=" | ||
app-alternatives/lex | ||
sys-devel/m4 | ||
virtual/pkgconfig | ||
nls? ( sys-devel/gettext ) | ||
verify-sig? ( >=sec-keys/openpgp-keys-elfutils-20240301 ) | ||
" | ||
|
||
PATCHES=( | ||
"${FILESDIR}"/${PN}-0.189-musl-aarch64-regs.patch | ||
"${FILESDIR}"/${PN}-0.189-musl-macros.patch | ||
) | ||
|
||
src_prepare() { | ||
default | ||
|
||
if ! use static-libs; then | ||
sed -i -e '/^lib_LIBRARIES/s:=.*:=:' -e '/^%.os/s:%.o$::' lib{asm,dw,elf}/Makefile.in || die | ||
fi | ||
|
||
# https://sourceware.org/PR23914 | ||
sed -i 's:-Werror::' */Makefile.in || die | ||
} | ||
|
||
src_configure() { | ||
# bug #407135 | ||
use test && append-flags -g | ||
|
||
# bug 660738 | ||
filter-flags -fno-asynchronous-unwind-tables | ||
|
||
multilib-minimal_src_configure | ||
} | ||
|
||
multilib_src_configure() { | ||
local myeconfargs=( | ||
$(use_enable nls) | ||
$(multilib_native_use_enable debuginfod) | ||
$(use_enable debuginfod libdebuginfod) | ||
|
||
# explicitly disable thread safety, it's not recommended by upstream | ||
# doesn't build either on musl. | ||
--disable-thread-safety | ||
|
||
# Valgrind option is just for running tests under it; dodgy under sandbox | ||
# and indeed even w/ glibc with newer instructions. | ||
--disable-valgrind | ||
--program-prefix="eu-" | ||
--with-zlib | ||
$(use_with bzip2 bzlib) | ||
$(use_with lzma) | ||
$(use_with zstd) | ||
) | ||
|
||
# Needed because sets alignment macro | ||
is-flagq -fsanitize=address && myeconfargs+=( --enable-sanitize-address ) | ||
is-flagq -fsanitize=undefined && myeconfargs+=( --enable-sanitize-undefined ) | ||
|
||
ECONF_SOURCE="${S}" econf "${myeconfargs[@]}" | ||
} | ||
|
||
multilib_src_test() { | ||
env LD_LIBRARY_PATH="${BUILD_DIR}/libelf:${BUILD_DIR}/libebl:${BUILD_DIR}/libdw:${BUILD_DIR}/libasm" \ | ||
LC_ALL="C" \ | ||
emake check VERBOSE=1 | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
|
||
dodoc NOTES | ||
|
||
# These build quick, and are needed for most tests, so don't | ||
# disable their building when the USE flag is disabled. | ||
if ! use utils; then | ||
rm -rf "${ED}"/usr/bin || die | ||
fi | ||
} |