Skip to content

Commit

Permalink
dev-tcltk/tclx: add 8.6.1
Browse files Browse the repository at this point in the history
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed May 27, 2023
1 parent 98b92dd commit 99978ae
Show file tree
Hide file tree
Showing 3 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-tcltk/tclx/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST tclx-8.4.4.tar.gz 456569 BLAKE2B 50123f95ed780c28dae9e2f0db956b81b559ee9ea33563b999f33a727c451374a63c0cba3012d4dd46df020426c7fdb3b04f932fc5b6ec742156e9dad81a7d3b SHA512 dcf9cbd08eae0cc4901e8e871a440e6c85d7d5ac923306206afaf0a1d931866ce3b91177d7b3a37e87a5cdcccb068ed7b9c76cb1a71a13f4f26cf204b8c42090
DIST tclx-8.6.1.tar.gz 457438 BLAKE2B 451b90a6f4403177604684a2a4475a057924faa4b625ac035d65b622b69e8dfea7146143056491ce8740374c18c4fbfb0184a0d074bf799897a01bb767e1695c SHA512 4a2293aad667b108f19f837686044fc168831781d04a9f8eaa2afe677c587f1e128a536ad9db609720e0046a20ff6f8dd7a0e5dd1232ef775c5a14e24ec0614d
1 change: 1 addition & 0 deletions dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
https://github.com/flightaware/tclx/pull/16#issuecomment-1565348180
--- a/configure.in 2023-03-15 22:00:11.725506240 +0100
+++ b/configure.in 2023-03-15 22:00:29.230246904 +0100
@@ -253,6 +253,7 @@
Expand Down
60 changes: 60 additions & 0 deletions dev-tcltk/tclx/tclx-8.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,60 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools

DESCRIPTION="A set of extensions to TCL"
HOMEPAGE="http://tclx.sourceforge.net"
SRC_URI="https://github.com/flightaware/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="threads"

DEPEND="dev-lang/tcl:0="
RDEPEND="${DEPEND}"

# tests broken, bug #279283
RESTRICT="test"

PATCHES=(
"${FILESDIR}"/${PN}-8.4-varinit.patch
"${FILESDIR}"/${PN}-8.4-ldflags.patch
"${FILESDIR}"/${PN}-8.4.4-musl.patch
)

QA_CONFIG_IMPL_DECL_SKIP=(
stat64 # used to test for Large File Support
)

src_prepare() {
default

sed \
-e '/CC=/s:-pipe::g' \
-i tclconfig/tcl.m4 configure || die

eautoreconf
}

src_configure() {
econf \
$(use_enable threads) \
--enable-shared \
--with-tcl="${EPREFIX}/usr/$(get_libdir)/"

# adjust install_name on darwin
if [[ ${CHOST} == *-darwin* ]]; then
sed -i \
-e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
"${S}"/Makefile || die 'sed failed'
fi
}

src_install() {
default
doman doc/*.[n3]
}

0 comments on commit 99978ae

Please sign in to comment.