Skip to content

Commit

Permalink
media-sound/positron: distutils-r1, EAPI=6
Browse files Browse the repository at this point in the history
  • Loading branch information
mgorny committed Feb 17, 2017
1 parent d3e26e9 commit 99ae53f
Showing 1 changed file with 9 additions and 14 deletions.
Original file line number Diff line number Diff line change
@@ -1,31 +1,26 @@
# Copyright 1999-2014 Gentoo Foundation
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="3"
PYTHON_DEPEND="2"
EAPI=6
PYTHON_COMPAT=( python2_7 )

inherit distutils
inherit distutils-r1

DESCRIPTION="Synchronization manager for the Neuros Audio Computer (www.neurosaudio.com) portable music player"
DESCRIPTION="Synchronization manager for the Neuros Audio Computer"
HOMEPAGE="http://www.xiph.org/positron"
SRC_URI="http://www.xiph.org/positron/files/source/${P}.tar.gz"

LICENSE="BSD"
SLOT="0"
KEYWORDS="x86 ppc sparc amd64"
KEYWORDS="amd64 ppc sparc x86"
IUSE="vorbis"

DEPEND="vorbis? ( dev-python/pyvorbis )"
DEPEND="vorbis? ( dev-python/pyvorbis[${PYTHON_USEDEP}] )"
RDEPEND="${DEPEND}"

pkg_setup() {
python_set_active_version 2
python_pkg_setup
}

src_prepare() {
distutils_src_prepare
python_prepare_all() {
# install docs in /usr/share/doc/${PF}, bug #241290
sed -i -e "s:share/doc/positron:share/doc/${PF}:" setup.py
distutils-r1_python_prepare_all
}

0 comments on commit 99ae53f

Please sign in to comment.