Skip to content

Commit

Permalink
dev-ruby/shotgun: add 0.9.2
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
graaff committed Sep 11, 2016
1 parent 015f4ac commit 99f9eac
Show file tree
Hide file tree
Showing 2 changed files with 38 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/shotgun/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST shotgun-0.9.1.gem 16384 SHA256 e426e4557ddd3a9a7015b06934aa30dc9038faf04bff5c5e9cd93a599c73ae8d SHA512 eae31007c4a27a660d4bc8bd0b87b4281c1c50a6c9c4675e492b8914a412dc5a2f21998f8b9105b0ada64600c1322d0bd936c4fd4b032dc57aaf1612827208f7 WHIRLPOOL 1bdce842ef3eb606a860052ea95315eb57e3237bd44d4aa76c5e360018377135ae69364e7550041f4492924bc7328b71b7be0203f566a02d004859396e6f68bb
DIST shotgun-0.9.2.gem 16384 SHA256 4ef19e63f98c620272666c98fa63e1e733c880b2ac112ac31578918fa2670411 SHA512 62228b0b8bdac815e2204fd89d3e106d033cfee7668ef12406120e5a21f52770ee36c6fa7b3edf3eaf09bdfde5849239364d3483a817914024c21618897e8d9a WHIRLPOOL c0143ba3cecf1281210b2cbfe4b68c68a13233750834a9ab2e3029fd5bf7841a8d499088cf249be0d3f7d95140202a3be141308d6760aa91346479ae37ac2bba
37 changes: 37 additions & 0 deletions dev-ruby/shotgun/shotgun-0.9.2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22 ruby23"

# No documentation task
RUBY_FAKEGEM_TASK_DOC=""

RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"

inherit ruby-fakegem

DESCRIPTION="Forking implementation of rackup"
HOMEPAGE="https://github.com/rtomayko/shotgun"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

# Warning: the code does not use gem versioning to make sure to load
# only the right rack version so we might need to patch it to work :/
ruby_add_rdepend 'dev-ruby/rack:*'
ruby_add_bdepend "test? ( dev-ruby/bacon )"

each_ruby_test() {
${RUBY} -Ilib test/test_shotgun_static.rb || die
${RUBY} -Ilib test/test_shotgun_loader.rb || die
}

all_ruby_install() {
all_fakegem_install

doman man/shotgun.1
}

0 comments on commit 99f9eac

Please sign in to comment.