Skip to content

Commit

Permalink
dev-python/oslo-vmware: bup for liberty
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
  • Loading branch information
prometheanfire committed Sep 3, 2015
1 parent 5288764 commit 99fb11e
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-python/oslo-vmware/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST oslo.vmware-0.11.2.tar.gz 102933 SHA256 036cf0ad6ab0d4defd743678999851d570c2ca1ff34eba916920ce54d9a5d348 SHA512 632635adcc09749d0fe8bd204e1b06374e9790cec4d53cbaa06b2afa6745460cd417d60df26cb1e287d6e9de98eaa09788c6797993a06d8649b765a9298d0f39 WHIRLPOOL dd77312f307e5f65a969bae52e52dbab175e4a25f627d3ccf35435ac64c551093b8b67b707388d46175d93f344e2731ebdfa2ba6062ac3b562a00877cc98b880
DIST oslo.vmware-0.7.0.tar.gz 69513 SHA256 c4c7f3b0a3734d357122beec977fea3cb48988c09c34ad4c5cfcd8211853484f SHA512 02e899613c23f4d7b2f46b7388a5a15aceae2537af0d9bf311b0b2a4b22d3afd534b07d0d444e1bfe2a0c0ae481924970a2b9b0274ca496dce1b6ff909f8eaab WHIRLPOOL 049cd90379a11b0e59884a25c5f8224bca40b8cdd28aaa5d8c2cc9da2c83850fb6ace2bd92cf04e665c4658831eb94bbaa3ffcbd702bb4e1e6663624d154bbd7
DIST oslo.vmware-1.21.0.tar.gz 83619 SHA256 afea2361aa1447efd2bc10d34636beadb718ecb4698d06fc3776ede498bff86a SHA512 2ca607de95d33ec175e09fa07438db8844c10da5929f2fa8d35ef8d63f628508f9c2de62e11ebc496e89c76d93c533413a973ab8b29219431d72770e19dd2d04 WHIRLPOOL 14fc58a01e94468b4eacd78d2d47fff623525edf5a9035957392b4ae5b1179798b3d6c667e87c266d698c861971eee2f24b2b2530ce9b8fc0ccbf2ad59f6c6aa
66 changes: 66 additions & 0 deletions dev-python/oslo-vmware/oslo-vmware-1.21.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,66 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )

inherit distutils-r1

DESCRIPTION="Oslo VMware library for OpenStack projects"
HOMEPAGE="https://pypi.python.org/pypi/oslo.vmware"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.vmware/oslo.vmware-${PV}.tar.gz"
S="${WORKDIR}/oslo.vmware-${PV}"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

CDEPEND="
>=dev-python/pbr-1.6[${PYTHON_USEDEP}]
<dev-python/pbr-2.0[${PYTHON_USEDEP}]"

DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}
test? (
>=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
>=dev-python/mock-1.2[${PYTHON_USEDEP}]
>=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]
>=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
>=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
>=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
>=dev-python/coverage-3.6[${PYTHON_USEDEP}]
>=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
!~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
<dev-python/sphinx-1.3[${PYTHON_USEDEP}]
>=dev-python/bandit-0.13.2[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
)"
RDEPEND="
${CDEPEND}
>=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]
>=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
!~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
>=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
>=dev-python/six-1.9.0[${PYTHON_USEDEP}]
>=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
>=dev-python/oslo-utils-2.0.0[${PYTHON_USEDEP}]
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
>=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
>=dev-python/suds-0.6[${PYTHON_USEDEP}]
>=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
>=dev-python/requests-2.5.2[${PYTHON_USEDEP}]
>=dev-python/urllib3-1.8.3[${PYTHON_USEDEP}]
>=dev-python/oslo-concurrency-2.3.0[${PYTHON_USEDEP}]
"
python_prepare() {
sed -i '/^suds-jurko/d' requirements.txt || die
sed -i '/^hacking/d' test-requirements.txt || die
}

python_test() {
nosetests tests/ || die "test failed under ${EPYTHON}"
}

0 comments on commit 99fb11e

Please sign in to comment.