Skip to content

Commit

Permalink
dev-db/mydumper: bump to 0.9.3
Browse files Browse the repository at this point in the history
  • Loading branch information
hydrapolic authored and Amynka committed Oct 8, 2017
1 parent 034cf61 commit 9a32f45
Show file tree
Hide file tree
Showing 3 changed files with 67 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/mydumper/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST mydumper-0.6.2.tar.gz 40165 SHA256 fa28563e8967752828954c5d81e26ef50aad9083d50a977bf5733833b23e3330 SHA512 ef9e48cc481f2674456659c061c45f3cb056180ab5576805e75d458658e94998758b894e45ddc06fb716c1d37fedefb644158f07cf6e77f4b5477663e954eb83 WHIRLPOOL 867b7efa6ca00dcfbb32f5dda2b63de038d0da3ac1a127059cbfdae9af577fef74868c38dad2bd5b5a9b4de76f7d108fcb6232b27c41d3062f413eac4cac843b
DIST mydumper-0.9.3.tar.gz 45320 SHA256 2cd6a074bac7072905bd044ec20955c53c81b10e877ac9c644509940a8d201fb SHA512 3bc2c85dbedf234aecca3b66f445e42bb7ddff83f914d5cc231f6a5755d1c2bf300ae9bf4bdea0717b45ea5338c6c336ec44f375dbf29570ed785ffddda53898 WHIRLPOOL 09988aa314ede6e56ce82c6eade9d29770ca2cbc39d4b2f1cd3f8403f9521e1aa5a372fda7992885c1c25743cc59d4c41cdce8d86eb79b8c7725631c2919c9ae
24 changes: 24 additions & 0 deletions dev-db/mydumper/files/mydumper-mariadb-include-fix.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
--- a/mydumper.c 2017-09-07 14:53:02.000000000 +0000
+++ b/mydumper.c 2017-10-06 17:39:34.962315949 +0000
@@ -22,6 +22,9 @@
#define _FILE_OFFSET_BITS 64

#include <mysql.h>
+#if defined(MARIADB_BASE_VERSION) && defined(MARIADB_VERSION_ID)
+ #include <server/mysql_version.h>
+#endif
#include <unistd.h>
#include <stdio.h>
#include <string.h>
--- a/myloader.c 2017-09-07 14:53:02.000000000 +0000
+++ b/myloader.c 2017-10-06 17:39:28.962315949 +0000
@@ -19,6 +19,9 @@
#define _FILE_OFFSET_BITS 64

#include <mysql.h>
+#if defined(MARIADB_BASE_VERSION) && defined(MARIADB_VERSION_ID)
+ #include <server/mysql_version.h>
+#endif
#include <unistd.h>
#include <stdio.h>
#include <string.h>
42 changes: 42 additions & 0 deletions dev-db/mydumper/mydumper-0.9.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

inherit cmake-utils

DESCRIPTION="A high-performance multi-threaded backup (and restore) toolset for MySQL"
HOMEPAGE="https://github.com/maxbube/mydumper"
SRC_URI="https://github.com/maxbube/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"

CDEPEND="dev-libs/glib:=
dev-libs/libpcre:=
dev-libs/openssl:=
sys-libs/zlib:=
virtual/mysql"
DEPEND="${CDEPEND}
virtual/pkgconfig
doc? ( dev-python/sphinx )"
RDEPEND="${CDEPEND}"

PATCHES=( "${FILESDIR}/${PN}-mariadb-include-fix.patch" )

src_prepare() {
# respect user cflags; do not expand ${CMAKE_C_FLAGS} (!)
sed -i -e 's:-Werror -O3 -g:${CMAKE_C_FLAGS}:' CMakeLists.txt || die

# fix doc install path
sed -i -e "s:share/doc/mydumper:share/doc/${PF}:" docs/CMakeLists.txt || die

cmake-utils_src_prepare
}

src_configure() {
local mycmakeargs=("-DBUILD_DOCS=$(usex doc)")

cmake-utils_src_configure
}

0 comments on commit 9a32f45

Please sign in to comment.