Skip to content

Commit

Permalink
games-puzzle/meandmyshadow: add 0.5a
Browse files Browse the repository at this point in the history
- no longer need to specify paths, adds prefix support
- opengl USE removed (option removed in sdl2 migration)
- switch to xdg.eclass
- add lua-single for now-required >=lua5.2 support
- add missing [ssl] and [jpeg] for add-ons, also [wav] for assets
- set more complete LICENSE for assets using data/Credits.txt

Closes: https://bugs.gentoo.org/763009
Signed-off-by: Ionen Wolkens <[email protected]>
  • Loading branch information
ionenwks committed Jun 1, 2021
1 parent 7422f81 commit 9a7029c
Show file tree
Hide file tree
Showing 2 changed files with 44 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-puzzle/meandmyshadow/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST meandmyshadow-0.4-src.tar.gz 16962805 BLAKE2B 607c08c0484b049e02ed54d2483f30f1c7af8aeffc31c977dba335e57eb14734517469f345387778875567db7f446b159dfbc7e51832cddc0d29e8352b308b29 SHA512 945f096fdc2df58b29f91314cd88953d897bbdbd094d8092d6712d33f7dbacadd298ca797e678ebad08ca579ed67a7b9d664e1fa202753e687a021935032a92b
DIST meandmyshadow-0.5a-src.tar.gz 17527733 BLAKE2B 76d47908ac0151981c0a597d7fac8bacc98895d7038943ff6f349c60156d503266acbb3875415f7552202f36bd21d97c1508a3e0a9fed501a65c5d4c1cca70ab SHA512 c9e6de9c9b47af3839b6830faa3619ddc69b2c2cabf4d90f4c1393758805acf9835abcba45d79037766b4b6e5f006e6f880eba593d1142b0e829a887eb844f27
43 changes: 43 additions & 0 deletions games-puzzle/meandmyshadow/meandmyshadow-0.5a.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,43 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

LUA_COMPAT=( lua5-{2..4} )
inherit xdg cmake lua-single

DESCRIPTION="Puzzle/platform game with a player and its shadow"
HOMEPAGE="https://acmepjz.github.io/meandmyshadow/"
SRC_URI="mirror://sourceforge/meandmyshadow/${PV}/${P}-src.tar.gz"

LICENSE="
Apache-2.0 BitstreamVera CC-BY-SA-3.0 CC-BY-SA-4.0 CC0-1.0
GPL-2+ GPL-3 GPL-3+ LGPL-2.1 OFL-1.1 public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
REQUIRED_USE="${LUA_REQUIRED_USE}"

RDEPEND="
${LUA_DEPS}
app-arch/libarchive:=
media-libs/libsdl2[sound,video]
media-libs/sdl2-image[jpeg,png]
media-libs/sdl2-mixer[vorbis]
media-libs/sdl2-ttf
net-misc/curl[ssl]"
DEPEND="${RDEPEND}"

DOCS=(
AUTHORS ChangeLog README.md
docs/{Controls,ScriptAPI,ThemeDescription}.md
)

src_configure() {
local mycmakeargs=(
-DLua_FIND_VERSION_MAJOR=$(ver_cut 1 $(lua_get_version))
-DLua_FIND_VERSION_MINOR=$(ver_cut 2 $(lua_get_version))
-DLua_FIND_VERSION_COUNT=2
-DLua_FIND_VERSION_EXACT=ON
)
cmake_src_configure
}

0 comments on commit 9a7029c

Please sign in to comment.