forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Gentoo-bug: 529242 Package-Manager: portage-2.2.27
- Loading branch information
1 parent
7e72237
commit 9a8eb22
Showing
2 changed files
with
58 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST CUnit-2.1-2-src.tar.bz2 349037 SHA256 1f705f30b36fe1dadb5494989d1d663241603f456b468c81f606a1bdbc168bea SHA512 c0af37b9f3a00fd7bb971f33e94373699d0380c28fad12f6db860739990a9ffffe0bb0a71c0e3531529b9952128c11248b8f365875d0315c16637a0b7e91642d WHIRLPOOL a5617aa10baf617e7165c04c66e4fffb25d2d8d396d8aff8ed5f67183154d79514d2c426c88bc02d02440f4c53bbe2b6025bbd0165fa3a6008e2b19e0317498b | ||
DIST CUnit-2.1-3.tar.bz2 514500 SHA256 f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214 SHA512 547b417109332446dfab8fda17bf4ccd2da841dc93f824dc90a20635bcf1fb80fb2176500d8a0906940f3f3d3e2f77b2d70a71090c9ab84ad9af43f3582bc487 WHIRLPOOL 621af4703fcaee5a222a55d735ac252ceed61dffa1d3d57e235ca952c13edfcd2d3dd3ef62623af40c57ae1e225868b8148d8268254fa724ddf936c85e4eadfa |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,57 @@ | ||
# Copyright 1999-2016 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
# $Id$ | ||
|
||
EAPI=6 | ||
inherit autotools eutils flag-o-matic multilib-minimal toolchain-funcs | ||
|
||
MY_PN="CUnit" | ||
MY_PV="${PV/_p*}-3" | ||
MY_P="${MY_PN}-${MY_PV}" | ||
|
||
DESCRIPTION="C Unit Test Framework" | ||
SRC_URI="mirror://sourceforge/cunit/${MY_P}.tar.bz2" | ||
HOMEPAGE="http://cunit.sourceforge.net" | ||
|
||
LICENSE="LGPL-2" | ||
SLOT="0" | ||
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos" | ||
IUSE="ncurses static-libs" | ||
|
||
RDEPEND="ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )" | ||
DEPEND="${RDEPEND}" | ||
|
||
S=${WORKDIR}/${MY_P} | ||
|
||
DOCS=( AUTHORS NEWS README ChangeLog ) | ||
|
||
src_prepare() { | ||
default | ||
|
||
sed -e "/^docdir/d" -i doc/Makefile.am || die | ||
sed -e '/^dochdrdir/{s:$(prefix)/doc/@PACKAGE@:$(docdir):}' \ | ||
-i doc/headers/Makefile.am || die | ||
sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die | ||
eautoreconf | ||
|
||
append-cppflags -D_BSD_SOURCE | ||
|
||
# unable to find headers otherwise | ||
multilib_copy_sources | ||
} | ||
|
||
multilib_src_configure() { | ||
local LIBS=${LIBS} | ||
append-libs $($(tc-getPKG_CONFIG) --libs ncurses) | ||
|
||
econf \ | ||
--docdir="${EPREFIX}"/usr/share/doc/${PF} \ | ||
$(use_enable static-libs static) \ | ||
--disable-debug \ | ||
$(use_enable ncurses curses) | ||
} | ||
|
||
multilib_src_install_all() { | ||
einstalldocs | ||
prune_libtool_files | ||
} |