forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-engines/stratagus: migrate to lua-single.eclass
Locked to lua5-1, both in upstream build scripts and by depending on dev-lua/toluapp. Closes: https://bugs.gentoo.org/752951 Signed-off-by: Marek Szuba <[email protected]>
- Loading branch information
Marek Szuba
committed
Dec 15, 2020
1 parent
5440d16
commit 9a945a1
Showing
2 changed files
with
72 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Copyright 1999-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
LUA_COMPAT=( lua5-1 ) | ||
|
||
inherit cmake lua-single | ||
|
||
DESCRIPTION="A realtime strategy game engine" | ||
HOMEPAGE="https://wargus.github.io/stratagus.html | ||
https://github.com/Wargus/stratagus" | ||
SRC_URI="https://github.com/Wargus/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="bzip2 debug doc fluidsynth mikmod mng theora vorbis" | ||
REQUIRED_USE="${LUA_REQUIRED_USE} | ||
theora? ( vorbis )" | ||
|
||
RDEPEND="${LUA_DEPS} | ||
dev-db/sqlite:3 | ||
dev-lua/toluapp[${LUA_SINGLE_USEDEP}] | ||
media-libs/libpng:0 | ||
virtual/opengl | ||
x11-libs/libX11 | ||
media-libs/libsdl[sound,opengl,video] | ||
sys-libs/zlib | ||
bzip2? ( app-arch/bzip2 ) | ||
fluidsynth? ( media-sound/fluidsynth ) | ||
mikmod? ( media-libs/libmikmod ) | ||
mng? ( media-libs/libmng ) | ||
vorbis? ( | ||
media-libs/libogg | ||
media-libs/libvorbis | ||
theora? ( media-libs/libtheora ) | ||
)" | ||
DEPEND="${RDEPEND}" | ||
BDEPEND=" | ||
virtual/pkgconfig | ||
doc? ( app-doc/doxygen )" | ||
|
||
PATCHES=( | ||
"${FILESDIR}/${PN}"-2.3.0-doc.patch | ||
) | ||
|
||
src_prepare() { | ||
sed -i -e 's:-Werror::' CMakeLists.txt || die | ||
cmake_src_prepare | ||
} | ||
|
||
src_configure() { | ||
# there are in-source switches | ||
use debug && CMAKE_BUILD_TYPE=Debug | ||
|
||
local mycmakeargs=( | ||
-DGAMEDIR="/usr/bin" | ||
-DDOCDIR="/usr/share/doc/${PF}" | ||
-DWITH_BZIP2=$(usex bzip2) | ||
-DWITH_FLUIDSYNTH=$(usex fluidsynth) | ||
-DWITH_MIKMOD=$(usex mikmod) | ||
-DWITH_MNG=$(usex mng) | ||
-DWITH_OGGVORBIS=$(usex vorbis) | ||
-DWITH_THEORA=$(usex theora) | ||
-DENABLE_DOC=$(usex doc) | ||
-DENABLE_DEV=ON | ||
) | ||
|
||
cmake_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters