Skip to content

Commit

Permalink
dev-php/swoole-async: initial import of v4.4.12
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/697690
Package-Manager: Portage-2.3.80, Repoman-2.3.19
Signed-off-by: Thomas Deutschmann <[email protected]>
  • Loading branch information
Whissi committed Nov 29, 2019
1 parent 5ba9e62 commit 9ab0a69
Show file tree
Hide file tree
Showing 3 changed files with 60 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-php/swoole-async/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST swoole-async-4.4.12.tar.gz 417674 BLAKE2B 77a96f53b1b159b558eb4759fe172e4a3b8f2648cd9f49252d89508eb56b4d342b178fa3c84d6a425c300a286063b4d32a05d09a3da4f3769be4c25a9800783c SHA512 adfb761803e5ec93c30aa2a4bbc312a2f43287a54cd237c0a87237dfcbfe1e6daa3d57ec2cdf15720202aa9a7830ed67ab2efdf2f7dd81989c3693e91bc22143
8 changes: 8 additions & 0 deletions dev-php/swoole-async/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>[email protected]</email>
<name>PHP Project</name>
</maintainer>
</pkgmetadata>
51 changes: 51 additions & 0 deletions dev-php/swoole-async/swoole-async-4.4.12.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI="7"

PHP_EXT_NAME="swoole_async"
PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_EXT_SAPIS="cli"
DOCS=( README.md )

USE_PHP="php7-1 php7-2 php7-3 php7-4"

inherit php-ext-pecl-r3

SRC_URI="https://github.com/swoole/ext-async/archive/v${PV}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/ext-async-${PV}"
PHP_EXT_S="${S}"

HOMEPAGE="https://www.swoole.co.uk"
KEYWORDS="~amd64 ~x86"

DESCRIPTION="An extension of Swoole, including the async callback style API"
LICENSE="Apache-2.0"
SLOT="0"
# Tests will require pre-configured endpoint
RESTRICT="test"

DEPEND=">=dev-php/swoole-4.3"

RDEPEND="${DEPEND}"

IUSE="debug"

src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-swoole_async
$(use_enable debug)
)

php-ext-source-r3_src_configure
}

src_test() {
local slot
for slot in $(php_get_slots); do
php_init_slot_env "${slot}"
[[ -f tests/template.phpt ]] && rm tests/template.phpt
SKIP_ONLINE_TESTS="yes" NO_INTERACTION="yes" emake test
done
}

0 comments on commit 9ab0a69

Please sign in to comment.