Skip to content

Commit

Permalink
dev-libs/jsoncpp: Bump to 1.9.5
Browse files Browse the repository at this point in the history
Signed-off-by: Michał Górny <[email protected]>
  • Loading branch information
mgorny committed Nov 3, 2021
1 parent e4a5ae3 commit 9ac2516
Show file tree
Hide file tree
Showing 2 changed files with 50 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-libs/jsoncpp/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST jsoncpp-1.9.3.tar.gz 212922 BLAKE2B 6f89762e899ffe127705a30c1fe86f458d62fa05b8dbde6c465c73b6855d3945f3d739ff0c26e1a6326a211c946277908684ace9363df72ba0f460f66b3e3fd8 SHA512 f1c035d54ed952d8d4e41acab5c3ecf6aa445f348f98aeac2e7c89555ec2f6421d727b3bc4c2f54176afce137c545b20d886562901953ec091f91890e91e8559
DIST jsoncpp-1.9.4.tar.gz 214057 BLAKE2B 9a8c52e5d0b78f1593c93bc40f48d3789b031ba0da519c99cce17f1f6e104b24e0ffe88138c25da6dfa250586aeb9e98d00fbf74d9fb9309b29a6d4f17762263 SHA512 adfd4afbdf6b79bd37edcf0e248f07864994f1c4bcb7431f3b44102490ce467f72381908066655fa486dec12f467af0a11f42f859bbf719895974c7339db7d22
DIST jsoncpp-1.9.5.tar.gz 216055 BLAKE2B 744275297647be8f1ac7bbf6c818e5106fc122591b3fb68c37cf33f5b3b7d6666e8429bb7ca2ae693202a5a83c274303804e21ebb27f05ba235568bf75a9b375 SHA512 1d06e044759b1e1a4cc4960189dd7e001a0a4389d7239a6d59295af995a553518e4e0337b4b4b817e70da5d9731a4c98655af90791b6287870b5ff8d73ad8873
49 changes: 49 additions & 0 deletions dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{8..10} )
inherit meson python-any-r1

DESCRIPTION="C++ JSON reader and writer"
HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
SRC_URI="
https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="|| ( public-domain MIT )"
SLOT="0/24"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="doc test"
RESTRICT="!test? ( test )"

BDEPEND="
${PYTHON_DEPS}
doc? ( app-doc/doxygen )"
RDEPEND=""

src_configure() {
local emesonargs=(
# Follow Debian, Ubuntu, Arch convention for headers location
# bug #452234
--includedir include/jsoncpp
-Dtests=$(usex test true false)
)
meson_src_configure
}

src_compile() {
meson_src_compile

if use doc; then
echo "${PV}" > version || die
"${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
HTML_DOCS=( dist/doxygen/jsoncpp*/. )
fi
}

src_test() {
# increase test timeout due to failures on slower hardware
meson_src_test -t 2
}

0 comments on commit 9ac2516

Please sign in to comment.