Skip to content

Commit

Permalink
app-crypt/johntheripper-jumbo: add 1.9.0_p20240102
Browse files Browse the repository at this point in the history
sync live
minor cleanup
Signed-off-by: Rick Farina <[email protected]>
  • Loading branch information
ZeroChaos- committed Jan 2, 2024
1 parent 6b09e2f commit 9af4de9
Show file tree
Hide file tree
Showing 3 changed files with 163 additions and 10 deletions.
1 change: 1 addition & 0 deletions app-crypt/johntheripper-jumbo/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST johntheripper-jumbo-1.9.0_p20211129.tar.gz 47758087 BLAKE2B de57218151fbc3bed79322d065ef73deb99b73fb1ce55924197793a320600cc1189dabae43fe5848014c2e72dcb7e1c2a91f2aaba64bd8c7314ded37e23a34c9 SHA512 f8fc6bf102d900bb32c5714bd595a71f67f73a1f0a237d9f851b2f250046307bf1177f3782023cd1bbcc55f9d54fd7b4946e09c7dc1fd908ba6a6bad90b233d6
DIST johntheripper-jumbo-1.9.0_p20230717.tar.gz 56772470 BLAKE2B 33295dc28d32852a6284adaadbbf9d9c852fb78e1dc673df5e67c31befb6921dbd6d29310ca7b3406e4b1259cca6e8d643292d73f4324262b038a1c6bc7ff51b SHA512 fd48a6bccf3f2be0d495aa8a635af73bc386c5815fdaa62259f2920724afa89e0e9743585c412e595486a0d2677f1ec43c43606471078ec0611d5c05b01853de
DIST johntheripper-jumbo-1.9.0_p20240102.tar.gz 55727974 BLAKE2B 10238f549b8d1d52d7858d0a0df080ae1e92a7026b3b31f4e19d00c2bf06df5ad1fe298291d5421a0f685786fca2ad954a5ed3b2adc23d80464ec1966db9c968 SHA512 c66898d12799d88d42e6a930768e27b4110362b6384a47957ab61300b8254af051d3a2821e54f12a90ded8a20c855b8a2f044942dba1605447ae355e2f7ecbaf
Original file line number Diff line number Diff line change
@@ -0,0 +1,156 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit autotools flag-o-matic toolchain-funcs pax-utils

DESCRIPTION="Fast password cracker, community enhanced version"
HOMEPAGE="http://www.openwall.com/john/"

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/openwall/john.git"
EGIT_BRANCH="bleeding-jumbo"
inherit git-r3
else
HASH_COMMIT="9daf16b5743b2c521d23c281e13ae8cdbd37b1eb"
SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/john-${HASH_COMMIT}"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="custom-cflags kerberos mpi opencl openmp pcap"

DEPEND=">=dev-libs/openssl-1.0.1:=
virtual/libcrypt:=
mpi? ( virtual/mpi )
opencl? ( virtual/opencl )
kerberos? ( virtual/krb5 )
pcap? ( net-libs/libpcap )
dev-libs/gmp:=
sys-libs/zlib
app-arch/bzip2"
# Missing (unpackaged):
# - Digest::Haval256
# - Digest::x
# See bug #777369.
# Pending keywording https://bugs.gentoo.org/921221
# dev-perl/Compress-Raw-Lzma
RDEPEND="${DEPEND}
dev-perl/Digest-MD2
virtual/perl-Digest-MD5
dev-perl/Digest-SHA3
dev-perl/Digest-GOST
!app-crypt/johntheripper"
RESTRICT="test"

pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

pkg_setup() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}

src_prepare() {
default

cd src || die
eautoreconf

sed -i 's#$prefix/share/john#/etc/john#' configure || die
}

src_configure() {
cd src || die

use custom-cflags || strip-flags

econf \
--enable-pkg-config \
--disable-native-march \
--disable-native-tests \
--disable-rexgen \
--with-openssl \
--with-systemwide \
$(use_enable mpi) \
$(use_enable opencl) \
$(use_enable openmp) \
$(use_enable pcap)
}

src_compile() {
# Uses default LD=$(CC) but if the user's set LD, it'll call it
# bug #729432.
emake LD="$(tc-getCC)" -C src
}

src_test() {
pax-mark -mr run/john

# this probably causes the following failure:
# Testing: as400-des, AS/400 DES [DES 32/64]... PASS
# Error, Invalid signature line trying to link to dynamic format.
# Original format=as400-ssha1
sed '/.include /d' run/john.conf > run/john-test.conf
if use opencl; then
# GPU tests fail in portage, so run cpu only tests
./run/john --config=run/john-test.conf --device=cpu --test=0 --verbosity=2 || die
else
# Weak tests
./run/john --config=run/john-test.conf --test=0 --verbosity=2 || die
# Strong tests
#./run/john --test=1 --verbosity=2 || die
fi

rm john-test.conf || die
}

src_install() {
# Executables
dosbin run/john
newsbin run/mailer john-mailer

pax-mark -mr "${ED}/usr/sbin/john"

# grep '$(LN)' Makefile.in | head -n-3 | tail -n+2 | cut -d' ' -f3 | cut -d/ -f3
local s
for s in \
unshadow unafs undrop unique ssh2john putty2john pfx2john keepass2john keyring2john \
zip2john gpg2john rar2john racf2john keychain2john kwallet2john pwsafe2john dmg2john \
hccap2john base64conv truecrypt_volume2john keystore2john
do
dosym john /usr/sbin/${s}
done

# Scripts
exeinto /usr/share/john
doexe run/*.pl
doexe run/*.py
insinto /usr/share/john
doins -r run/lib
cd run || die

local s
for s in *.pl *.py; do
dosym ../share/john/${s} /usr/bin/${s}
done
cd .. || die

if use opencl; then
insinto /etc/john
doins -r run/opencl
fi

# Config files
insinto /etc/john
doins run/*.chr run/password.lst
doins run/*.conf
doins -r run/rules run/ztex

# Documentation
rm -f doc/README || die
dodoc -r README.md doc/*
}
16 changes: 6 additions & 10 deletions app-crypt/johntheripper-jumbo/johntheripper-jumbo-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2023 Gentoo Authors
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -8,20 +8,14 @@ inherit autotools flag-o-matic toolchain-funcs pax-utils
DESCRIPTION="Fast password cracker, community enhanced version"
HOMEPAGE="http://www.openwall.com/john/"

MY_PN="JohnTheRipper"

if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/magnumripper/${MY_PN}.git"
EGIT_REPO_URI="https://github.com/openwall/john.git"
EGIT_BRANCH="bleeding-jumbo"
inherit git-r3
else
JUMBO="jumbo-1.1"
MY_PV="${PV}-${JUMBO}"
MY_P="john-${MY_PV}"
HASH_COMMIT="5d0c85f16f96ca7b6dd06640e95a5801081d6e20"

HASH_COMMIT="9daf16b5743b2c521d23c281e13ae8cdbd37b1eb"
SRC_URI="https://github.com/openwall/john/archive/${HASH_COMMIT}.tar.gz -> ${P}.tar.gz"
S="${WORKDIR}/john-${HASH_COMMIT}"

KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
fi

Expand All @@ -42,6 +36,8 @@ DEPEND=">=dev-libs/openssl-1.0.1:=
# - Digest::Haval256
# - Digest::x
# See bug #777369.
# Pending keywording https://bugs.gentoo.org/921221
# dev-perl/Compress-Raw-Lzma
RDEPEND="${DEPEND}
dev-perl/Digest-MD2
virtual/perl-Digest-MD5
Expand Down

0 comments on commit 9af4de9

Please sign in to comment.