Skip to content

Commit

Permalink
dev-perl/BSON: Bump to version 1.6.7
Browse files Browse the repository at this point in the history
Upstream:
- Validate Uint32 ranges on BSON::Timestamp components
- Adds comparison overloading to BSON::OID
- Adds create_oid class method
- Adds comparison overloading to BSON::Timestamp
- 'prefer_numeric' applies heuristic to dualvars only when no numeric
  form already exists
- epoch method on BSON::Time now floating point, not truncated to
  integer
- Fixed PID generation within OIDs
- Fix backwards compatible BSON::Timestamp constructor so
  MongoDB::Timestamp can be an empty subclass
- Add "bool" overloading for BSON::String to avoid fallback numification
  warnings
- Fix BSON::Time epoch conversion on perl w/ 64bit ints
- Improve BSON::Timestamp comparison to undef
- Prevent deprecation warnings from use of deprecated MongoDB v2 classes
  in test code
- Remove legacy tests for MongoDB::BSON::_EncodedDoc

Package-Manager: Portage-2.3.40, Repoman-2.3.9
  • Loading branch information
kentfredric committed Aug 18, 2018
1 parent 82d177f commit 9af72ff
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
44 changes: 44 additions & 0 deletions dev-perl/BSON/BSON-1.6.7.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

DIST_AUTHOR=MONGODB
DIST_VERSION=v1.6.7
inherit perl-module

DESCRIPTION="BSON serialization and deserialization"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"

RDEPEND="
virtual/perl-Carp
virtual/perl-Digest-MD5
virtual/perl-Exporter
virtual/perl-MIME-Base64
virtual/perl-Math-BigInt
>=dev-perl/Moo-2.2.4
virtual/perl-Scalar-List-Utils
dev-perl/Tie-IxHash
virtual/perl-Time-HiRes
virtual/perl-Time-Local
>=dev-perl/boolean-0.450.0
virtual/perl-if
dev-perl/namespace-clean
virtual/perl-threads-shared
virtual/perl-version
"
DEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.170.0
test? (
>=virtual/perl-CPAN-Meta-2.120.900
virtual/perl-Data-Dumper
virtual/perl-File-Spec
dev-perl/JSON-MaybeXS
>=dev-perl/Path-Tiny-0.54.0
dev-perl/Test-Deep
>=virtual/perl-Test-Simple-0.960.0
)
"
1 change: 1 addition & 0 deletions dev-perl/BSON/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST BSON-v1.4.0.tar.gz 99911 BLAKE2B e993b22721f80b444a701dc5017792b54db475abe53e997baba9314b4c30aca0e8f88173d4caa70bbc07fae8131a5f2618bbcba0f3b27b1578b20447c6f3549f SHA512 3904ad3e426514fc826ef3dea31c93c9ce22e3b0d4b4790528e8eba91412e7dc626b44c08a43fb528780bd53a29d25a5b9ad6fd270cfb52fe8e3fdcbc3ba5afe
DIST BSON-v1.6.7.tar.gz 104454 BLAKE2B 1c72127bcb1dae99bc193c63d4db4eae10cdfb78c03da543b288ea6134a3062dc896da185835c26481636f3b88b2864ac58932c4961cee348bae30a606ee4e1f SHA512 bb3e9f64a09dbdc79cf321cf7807bfb90744bbc2556f0a0c4538fcbbcd8e89e9b79758258306c13da6dc794f8962ec2cb8886f3167775a71ec8d4b69de92b3ee

0 comments on commit 9af72ff

Please sign in to comment.