Skip to content

Commit

Permalink
app-misc/inputlircd: use #!/sbin/openrc-run instead of #!/sbin/runscript
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846

Package-Manager: portage-2.2.26
  • Loading branch information
austin987 committed Apr 26, 2016
1 parent 49c6e18 commit 9b0d600
Show file tree
Hide file tree
Showing 4 changed files with 70 additions and 2 deletions.
2 changes: 1 addition & 1 deletion app-misc/inputlircd/files/inputlircd.init
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
#!/sbin/runscript
#!/sbin/openrc-run

start() {
ebegin "Starting lircd"
Expand Down
2 changes: 1 addition & 1 deletion app-misc/inputlircd/files/inputlircd.init.2
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
#!/sbin/runscript
#!/sbin/openrc-run

depend() {
provide lirc
Expand Down
34 changes: 34 additions & 0 deletions app-misc/inputlircd/inputlircd-0.0.1_pre11-r2.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

inherit toolchain-funcs

DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
HOMEPAGE="http://svn.sliepen.eu.org/inputlirc/trunk"
SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.bz2"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""

DEPEND=""
RDEPEND=""

src_unpack() {
unpack ${A}
cd "${S}"
sed -e 's:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' -i Makefile || die
}

src_compile() {
emake CC="$(tc-getCC)" || die "make failed"
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"

newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
newconfd "${FILESDIR}"/inputlircd.conf inputlircd
}
34 changes: 34 additions & 0 deletions app-misc/inputlircd/inputlircd-0.0.1_pre15-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

inherit toolchain-funcs

DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
HOMEPAGE="http://svn.sliepen.eu.org/inputlirc/trunk"
SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
IUSE=""

DEPEND=""
RDEPEND=""

src_unpack() {
unpack ${A}
cd "${S}"
sed -e 's:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' -i Makefile || die
}

src_compile() {
emake CC="$(tc-getCC)" || die "make failed"
}

src_install() {
emake DESTDIR="${D}" PREFIX=/usr install || die "emake install failed"

newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
newconfd "${FILESDIR}"/inputlircd.conf inputlircd
}

0 comments on commit 9b0d600

Please sign in to comment.