Skip to content

Commit

Permalink
x11-libs/xforms: EAPI 6 bump. Version bump.
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.28
  • Loading branch information
monsieurp committed Jun 12, 2016
1 parent 9f682a3 commit 9b1c77f
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions x11-libs/xforms/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xforms-1.0.93sp1.tar.gz 2204088 SHA256 0cbef8c16c478b7fc87cf24be618114f9b7d14dc0a06b61a352bb027dd3b2ca4 SHA512 b352b345f110966741f82645f1282805dd27e4eb16642efedb4f7e0132a109f525da678052b501d1d520014bb7f754f5b53676a83cfab5a249c02db835c66a6a WHIRLPOOL e5d83d3aef7bc06612afa6a64f01bbc101c796ae4baf65198088627fcf9e241285707cf9d92b01927fe5970cc8c0e1f1ceb829037c224e0fbb37f41b4997ab54
DIST xforms-1.2.4.tar.gz 1438503 SHA256 073aea6514959b81b5a82430df3308abf1072b75c909bb915c0e1ebe86d1a8a3 SHA512 93a37dcb9d5cafbca5a6992ba36234c8f9cf0c658e2a2d664b290f5fc39f1239498d97ea3f88230f097a62ed37813cf3c1bd84e98b92e03f1ac0cecfb62565f8 WHIRLPOOL 08e7c8b9740303a91a8cf61234b62455c06e87c6a79c83a13abf748254fa5a776b0bdfa75c4727ac2425c63e12f2d93397c825b4111d4dc767beb5e82c1e1cef
50 changes: 50 additions & 0 deletions x11-libs/xforms/xforms-1.2.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit autotools eutils

MY_P="${P/-/_}"

DESCRIPTION="A graphical user interface toolkit for X"
HOMEPAGE="http://xforms-toolkit.org/"
SRC_URI="http://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${MY_P}.tar.gz -> ${P}.tar.gz"

LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="doc opengl static-libs"

RDEPEND="
virtual/jpeg:0=
x11-libs/libSM
x11-libs/libX11
x11-libs/libXpm
opengl? ( virtual/opengl )"

DEPEND="
${RDEPEND}
x11-proto/xproto"

S=${WORKDIR}/${MY_P}

DOCS=( ChangeLog NEWS README )

src_prepare() {
default
AT_M4DIR=config eautoreconf
}

src_configure() {
econf \
$(use_enable doc docs) \
$(use_enable opengl gl) \
$(use_enable static-libs static)
}

src_install() {
default
prune_libtool_files
}

0 comments on commit 9b1c77f

Please sign in to comment.