Skip to content

Commit

Permalink
dev-db/mysql-workbench: fix gcc13 compilation
Browse files Browse the repository at this point in the history
Thanks to Alex D-Bug for the patch.

Closes: https://bugs.gentoo.org/905758
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Jul 8, 2023
1 parent c5e07df commit 9b58cf1
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 0 deletions.
40 changes: 40 additions & 0 deletions dev-db/mysql-workbench/files/mysql-workbench-8.0.33-gcc13.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,40 @@
--- mysql-workbench-community-8.0.33-src/library/forms/mforms/mforms.h.orig 2023-06-30 14:43:47.056539087 +0300
+++ mysql-workbench-community-8.0.33-src/library/forms/mforms/mforms.h 2023-06-30 14:44:11.500537735 +0300
@@ -61,6 +61,7 @@
*
*/

+#include <cstdint>
#include "mforms/view.h"
#include "mforms/form.h"
#include "mforms/button.h"
--- mysql-workbench-community-8.0.33-src/library/cdbc/src/driver_manager.h.orig 2023-06-30 14:51:19.804514044 +0300
+++ mysql-workbench-community-8.0.33-src/library/cdbc/src/driver_manager.h 2023-06-30 14:51:30.333513462 +0300
@@ -27,6 +27,7 @@
#include "cppdbc_public_interface.h"

#include <cppconn/driver.h>
+#include <cstdint>
#include <memory>
#include <set>

--- mysql-workbench-community-8.0.33-src/library/forms/mforms/treeview.h.orig 2023-06-30 17:08:50.534057671 +0300
+++ mysql-workbench-community-8.0.33-src/library/forms/mforms/treeview.h 2023-06-30 17:10:33.945051951 +0300
@@ -23,6 +23,7 @@

#pragma once

+#include <cstdint>
#include <mforms/view.h>

/**
--- mysql-workbench-community-8.0.33-src/backend/wbpublic/sqlide/sqlide_generics_private.h.orig 2023-06-30 17:51:48.242915090 +0300
+++ mysql-workbench-community-8.0.33-src/backend/wbpublic/sqlide/sqlide_generics_private.h 2023-06-30 17:52:26.461912976 +0300
@@ -24,6 +24,7 @@
#ifndef _SQLIDE_GENERICS_PRIVATE_H_
#define _SQLIDE_GENERICS_PRIVATE_H_

+#include <cstdint>
#include "wbpublic_public_interface.h"
#include <sqlite/database_exception.hpp>
#include <sqlite/result.hpp>
1 change: 1 addition & 0 deletions dev-db/mysql-workbench/mysql-workbench-8.0.33.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -70,6 +70,7 @@ S="${WORKDIR}"/"${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-6.2.5-wbcopytables.patch"
"${FILESDIR}/${PN}-8.0.19-mysql-connector-8.patch"
"${FILESDIR}/${PN}-8.0.33-gcc13.patch"
)

src_unpack() {
Expand Down

0 comments on commit 9b58cf1

Please sign in to comment.